X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to force Firefox to use a default profile on startup?

Kuphostiwe

I have two profiles for firefox. But sometimes Firefox starts with the first active, sometimes with the second. The question is: How can I force firefox to use the profile "default" as the default profile on startup when there is no other instance running? When I want to use a second profile in parallel I use the command "firefox -P --no-profile" to start the profile selector.

I have two profiles for firefox. But sometimes Firefox starts with the first active, sometimes with the second. The question is: How can I force firefox to use the profile "default" as the default profile on startup when there is no other instance running? When I want to use a second profile in parallel I use the command "firefox -P --no-profile" to start the profile selector.

Eminye Imininingwane Yohlelo

Fakela amapulagi

see above

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Linux Mint/8 (Helena) Firefox/3.5.9

Eminye Imininingwane

No-Script, Firebug, Mint-Search Enhancer, Stylish. (all the latest)

cor-el
  • Top 10 Contributor
  • Moderator
17467 izisombululo 157849 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Use the profile manager to set the default profile that you want to use and tick the box to always use that choice. After having set that you need to revert from using the Profile Manager and only use desktop shortcut that specifies the profile to use to avoid changing that setting.

The default profile set in profiles.ini is used when you click a link in an external program and Firefox isn't open yet. Be careful with using the -no-remote switch as that makes that Firefox instance invisible to links clicked in external programs.

http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

Use the profile manager to set the default profile that you want to use and tick the box to always use that choice. After having set that you need to revert from using the Profile Manager and only use desktop shortcut that specifies the profile to use to avoid changing that setting. The default profile set in profiles.ini is used when you click a link in an external program and Firefox isn't open yet. Be careful with using the -no-remote switch as that makes that Firefox instance invisible to links clicked in external programs. http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 izisombululo 40134 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Also, the Profile with the line Default=1 in the profiles.ini file is the Profile that Firefox will use as the "default" Profile for external programs; the "name" of the Profile has nothing to do with it.

Also, the Profile with the line '''Default=1''' in the '''''profiles.ini''''' file is the Profile that Firefox will use as the "default" Profile for external programs; the "name" of the Profile has nothing to do with it.
zarezadeh 0 izisombululo 1 izimpendulo
Kuphostiwe

Also be sure that StartWithLastProfile is set 0 in profiles.ini so firefox does not change default profile every time shuts down.


[General]

StartWithLastProfile=0

Also be sure that ''StartWithLastProfile'' is set 0 in ''profiles.ini'' so firefox does not change default profile every time shuts down. ''[General]'' ''StartWithLastProfile=0''

Okulungisiwe ngu zarezadeh

Lyndhurst 0 izisombululo 1 izimpendulo
Kuphostiwe

You will need to open "profiles.ini" in Wordpad or Notepad and edit it. Please note that I am runnig Windows 7 and Firefox 11. On my computer, the path to my profile.ini file is: "c:\Users\Lyndhurst\AppData\Roaming\Mozilla\Firefox". When you open the file you should see your profiles (1 or more) and the profile that opens first has an extra line that says "Default=1". You need to move that line to the profile that you want to open first, either by using "cut and paste" or by deleting it and re-typing it. Hope this helps.

You will need to open "profiles.ini" in Wordpad or Notepad and edit it. Please note that I am runnig Windows 7 and Firefox 11. On my computer, the path to my profile.ini file is: "c:\Users\Lyndhurst\AppData\Roaming\Mozilla\Firefox". When you open the file you should see your profiles (1 or more) and the profile that opens first has an extra line that says "Default=1". You need to move that line to the profile that you want to open first, either by using "cut and paste" or by deleting it and re-typing it. Hope this helps.