Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Want to turn this off: This Connection is Untrusted You have asked Firefox to connect securely to login.facebook.com, but we can't confirm that your connection is secure. Normally, when yo

  • 3 uphendule
  • 661 zinale nkinga
  • 8438 views
  • Igcine ukuphendulwa ngu cor-el

more options

Want to turn this off: This Connection is Untrusted

You have asked Firefox to connect securely to login.facebook.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

Technical Details

login.facebook.com uses an invalid security certificate.

The certificate will not be valid until 7/23/2009 8:03 AM.

(Error code: sec_error_expired_certificate)

I Understand the Risks

Okulungisiwe ngu cor-el

All Replies (3)

more options

"The certificate will not be valid until 7/23/2009 8:03 AM. "

Is the date / time on your PC set correctly? Right-click the time in the System Tray (lower-right corner of your screen) and select Adjust Date / Time.

more options

My date/time is correct, nevertheless ---

I continue to have this problem, and I've asked about it at Firefox and other forums. Even worse, the Settings pages for both Facebook and Twitter cause the same error pop up, and only load in html, with no hyperlinks. I.e. I cannot even delete my Facebbook or Twitter accounts, because of the only partially loaded settings page.

Okulungisiwe ngu dcsouthpaw

more options

Did you check the year to be sure?

"will not be valid until ..2009" clearly indicates that Firefox thinks that the date is before 2009

Check the date and time in the clock on your computer: Double click the clock icon on the Windows Taskbar.


You can try to rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to remove all intermediate certificates that Firefox has stored by visiting secure websites.

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Okulungisiwe ngu cor-el