Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My Homepage opens in Japanese. How do I change it to open in English?

  • 3 uphendule
  • 22 zinale nkinga
  • 571 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

This is my reply to the-edmiester's answer https://support.mozilla.com/en-US/forum/1/724605#threadId724733 . Post a Reply would not work.

My reply: Thanks but does not solve problem. 873 is to change to another country (language) homepage. I have the UK homepage address in the web page location bar at top of page, i.e. http://www.google.co.jp/firefox?client=firefox-a&rls=org.mozilla:en-GB:official but the page is showing Japanese text.

This happened

Every time Firefox opened

From installation

User Agent

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 2.0.50727)

All Replies (3)

more options

Why aren't you using Firefox in this forum? After all, you are asking for support for Firefox.

This is the UK Firefox / Google homepage? http://www.google.co.jp

The jp suffix is Japan, isn't it?

more options

Google.com in English - always '.com': https://addons.mozilla.org/firefox/addon/51000


You can click the link at the bottom of the local Google page to go to the "Google.com in English" site. You need to hover the local Google page (www.google.co.jp) with the mouse to make more content appear. You can set the Google preferences on the Google Search settings page (link at the top right). Such settings are stored in a cookie on your computer that you need to allow: Tools > Options > Privacy > Cookies: "Exceptions" or Tools > Page Info > Permissions.

more options

Hi cor-el Thanks, that helps with the Search function.


the-edmeister "Why aren't you using Firefox in this forum? After all, you are asking for support for Firefox. "

er.... I downloaded 'Firefox Setup 3.6.6.exe' from the Mozilla site and installed as per instructions. I have a Mozilla Firefox icon on my desktop which I click and it takes me into what I thought was Firefox. If I am not in Firefox what am I in?

"This is the UK Firefox / Google homepage? http://www.google.co.jp "

er.... If I hover over the 'Home' button I see http://en-GB.start3.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-GB:official If I click the 'Home' button http://www.google.co.jp/firefox?client=firefox-a&rls=org.mozilla:en-GB:official appears in the web page location bar to the right of the 'Home' button

So you tell me what the UK Firefox / Google homepage is?

"The jp suffix is Japan, isn't it?"

er.... Yes it is, but that is what the system is giving me .... so how do I set it to .uk suffix?