Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox opens two icons in dock when I launch it. Why?

  • 52 uphendule
  • 58 zinale nkinga
  • 604 views
  • Igcine ukuphendulwa ngu blueskies238

more options

Whenever I launch Firefox 4, two Firefox icons appear in my dock. Why does this happen and how can I have just one icon launch? I'm using a Mac.

This happened

Every time Firefox opened

== I installed Firefox 4 on my iMac

All Replies (12)

more options

Same happens here. Intel Mac 10.6.4

more options

Same here, I guess this is because FF4 is 64bits and Flash Player is not, hope they'll find a workaround for beta 2.

more options

count++; //same problem here

more options

Same problem. Everything's ok until I open a site with flash content, then then second ff icon appears in the dock. OSX 10.6.4

more options

It started happening after installing Flash 10.1.

more options

Same here.. please fix soon!

more options

same here :-/

more options
more options

Same here.

10.6.4

FF 4.b1

more options

Try this...I fixed it on my win 7 machine. Open firefox with the button on your taskbar. Now, after there are two icons, right click on the original one you clicked on and unpin it from the task bar. Now close the other instance. You should have NO icons for firefox left on the taskbar. Next, click the start button and enter firefox in the search box (where macs is I'm not sure) only DON"T hit enter. Right click on the firefox found by the search and select "Pin to task bar". This fixed the issue for me. Now I only have one instance of the icon on the taskbar when I launch it.

Okulungisiwe ngu blueskies238

  1. 1
  2. 2
  3. 3