Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

windows 7 firefox 3.6.6 google search freezes on first page

  • 49 uphendule
  • 283 zinale nkinga
  • 186 views
  • Igcine ukuphendulwa ngu tphilbri

more options

FIREFOX 3.6.6 FREEEZEZ ON GOOGLE FIRST SEARCH PAGE

Dear Mozilla,

As of the last update to 3.6.6 when one searches anything in GOOGLE the Firefox will take you to the first searched page. Any attempts to click on any other page or the 'next' arrow results in a little box appearing where you are clicking and then basically nothing.

That's all you get. The web address for the next page search appears in the address bar but the page never appears...Firefox leaves you sitting one page in.

If you hit the 'refresh' icon the browser will move to the next indicated page but then that's it again. Help!!! I rolled bacl to version 3.5.6 but this still keeps occurring, suggesting that my registry has become corrupted in regards to Mozilla. Thanks Bill



URL of affected sites

http://google.com

User Agent

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0)

Isisombululo esikhethiwe

I had this problem at 8am yesterday (Mac OSX 10.4.11), now it's working correctly (12:30am). I guess it was google....

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (9)

more options

I abandoned IE in Jan. of this year after spending &1K getting viruses off my computers. Up till now, Firefox has been incredible.

Unfortunatelly, there have been some compatability issues and I have also been prepared to use Chrome. It seems one must have at least two working browsers in the present internet environment. I suppose I'll Uninstall and come back to FF in a couple of months, staying away from updated browsers for at least 4-6 mos.

What next? Opera, here I come!

more options

Firefox is highly unstable from my experiences. I will be reverting back to Chrome until this is fixed. It seems Firefox is not yet compatible with Windows7 or better yet not compatible with Windows at all.

Frequent crashes and freezing is very annoying, making it impossible to complete my work. Goodbye Firefox, I can no longer support you. :(

And to the anonymous user that blames Google for the problem, that is absurd. What kind of solution is that! If you cannot post a "REAL SOLUTION" then don't bother at all!

Okulungisiwe ngu developerNC

more options

I have experienced this very same problem recently with FF 3.6.8

Several things were temporary work arounds, like using iGoogle or

https://www.google or turning off java script. But these are not great.

I fixed the problem by running Ccleaner

http://www.piriform.com/ccleaner

I noticed that ccleaner deleted the 'downloads.sqlite' file from my FF profile directory. That file may have been the root of the problem since Mozilla was suggesting that the problem may be in the formhistory.sqlite file.

-eo

more options

Just after posting this last reply, I think I accidentally ran across the real answer.

I thought that I fixed the problem running Ccleaner, but then I did a 'restart' (using the restart FF command on the 'File' menu) and the problem with the Google search button showed up again.

I then deleted all my Google related tabs, cleared the Cache and closed FF completely and started it from my Desktop Icon. The Google search button began to work again.

I repeated this 3 times. Every time I did a restart of FF from within FF, the Google search button stopped working. And then I fixed it by deleting any Google related tabs, clearing the Cache and closing FF altogether and starting it up from Windows (Vista).

Something to look out for because FF asks you to 'Restart' FF from within FF a lot these days. Whenever you update anything.

-eo

more options

I too must abandon Firefos version 3.6.10 as it freezes many times in a day and is keeping me from enjoying the browser anymore, so Google Chrome is the answer for now. I'm using Windows 7 x64 bit with 24 gigs of ram and this browser crashes & freezes way too much , get things together please before releasing updates as these updates have effectively ruined this otherwise gr8 browser.

more options

I have the same thing on FF 3.6.12 with No Script. I had to block google & it works now the bar at the bottom come up still but I can get to other pages weird

more options

If you have McAfee Site Advisor installed as an Add-On either disable or uninstall it. After disabling it on the Firefox 4 beta, I can access Google again without it freezing activity on the browser.

more options

Absolutely the same problem as everyone else above. There is a reoccurring with the updates from Firefox. This has happened to me several times in the past. The new updates are downloaded automatically and then Firefox either quits working or will not work correctly.

With version 4 the window loads half way and stops. That's it. "No longer responding" is what you get.

I tried the uninstall as suggested and then went to download version 4 from the website only to find out it is a corrupt file.

I finally uninstalled everything again and then reinstalled 3.6.13. It works fine so far.

The big question is how to turn off the "Automatic Updates". Does anyone know how this might be done? Because you sure can't get any help from the Firefox support staff.

There should be an option when you first install Firefox to choose if you want to get the updates manually or automatically. I would love to get hold of a tech, or "anyone" else at the company to suggest this, but again: How do you contact anyone? There is never anyone in the live chat no matter what time of day you try.

I like Firefox, but their support truly sucks. So if anyone has any idea at all of how to turn the LIVE UPDATE feature off for Firefox, I would dearly love to see someone give the directions to do so in this forum. If Firefox doesn't get this fixed pretty soon I will go back to IE7. Thank you. My rant is now done.

more options

I've been getting this for some time now. Laptop reboot seems to help it go away for a while. Deleting FF folders and user settings and uninstalling and then reinstalling, are only eating my time. Typing in any search string in the google search bar or in the google search page, result in an immediate freeze. Hangs and requires shut down. Many times, restarting just brings the hang back. I've resorted to using, and I reaaaalllly hate saying this word, Bing for searches. Finding Chrome is a more reliable solution. Just wondering if this is some devious plan on Google's end? Freezes only when I do G searches. What's up?

  1. 1
  2. 2
  3. 3