Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox will not open on startup

  • 3 uphendule
  • 27 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Morbus

more options

After installing the latest Windows Updates (which may or may not be relevant), Firefox crashes at every startup. I restarted the computer and tried running Firefox in safe mode, and it continues to crash. I have been through the support pages already, and these do not seem to fix the problem.

Crash ID(s)


User Agent

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)

Isisombululo esikhethiwe

Kelsey, try reinstalling Firefox. You can get the latest version (for free, as always) at

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Hello Kelsey.

Hopefully this support article is what you need:

In any case, you may be having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not coming from one of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode and select Disable all add-ons. If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and theme. You can troubleshoot plugins the same way.

If you want support for one of your add-ons, you'll need to contact its author.

more options

I cannot run Firefox in safe mode, so I can't disable add-ons. I continue to get the crash message when I try to run safe mode. I have been through that support page already, and none of the solutions seemed to match my problem.

more options

Isisombululo Esikhethiwe

Kelsey, try reinstalling Firefox. You can get the latest version (for free, as always) at