Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox is playing mp3/wav after clicking links to it instead of showing dialog for play/download

  • 5 uphendule
  • 70 zinale nkinga
  • 13419 views
  • Igcine ukuphendulwa ngu capfed76

more options

Firefox trying to play wavs/mp3s after clicking link to it instead of showing dialog to open/download. In preferences in applications tab I've selected "always ask" in wav and mp3 file types, but it didn't solve this problem.

This happened

Every time Firefox opened

== I am unsure

Isisombululo esikhethiwe

Firefox will play the file if you have a player installed that supports the mime type that the server sends for that file.

See "File handling in Firefox 3 and SeaMonkey 2": http://kb.mozillazine.org/File_types_and_download_actions

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Isisombululo Esikhethiwe

Firefox will play the file if you have a player installed that supports the mime type that the server sends for that file.

See "File handling in Firefox 3 and SeaMonkey 2": http://kb.mozillazine.org/File_types_and_download_actions

more options

The reply posted Jun 18 regarding mime types is irrelevant to the actual problem. The difficulty is files play instead of downloading regardless of how preferences are set. This means it is virtually impossible to download mp3 arghhhhhh! Any other suggestions would be greatly appreciated!

more options

Although right-clicking on the MP3 link would allow it to be downloaded, I agree that Firefox should respect the preferences specified in the Applications tab of Preferences, and it is very misleading to allow the user to select "Always Ask" for MP3, then completely ignore this due to the presence of a plugin.

more options

Go to about:config (click "I'll be careful, I promise")

Find plugin.disable_full_page_plugin_for_types

Right click on the line of text and click Modify

If there is no value in there then enter audio/mpeg If there are already values add ,audio/mpeg at the end (comma is important)

Click OK Restart Firefox

Now clicking on an mp3 will ask where to download

Okulungisiwe ngu pollen

more options

Thank you for this tip, I was going mad, I had set all the mime types to always ask but firefox always playing mp3s using the vlc plugin instead of asking. I manually created the value and after restarting firefox it started asking what to do! :-)