Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Dozens of Firefox windows open quickly on my IMac when I access a PDF. Must always ForceQuit.

  • 3 uphendule
  • 8 zinale nkinga
  • 10 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

When I open a PDF on my IMac, dozens of Firefox windows open very quickly in succession. The only way to stop this is to Force Quit Firefox. I can no longer use Firefox as my default browser because of this problem. The Apple support team had me uninstall and reinstall both Firefox and Adobe, to no avail. Thanks for your help.

This happened

A few times a week

== Not certain.

Isisombululo esikhethiwe

Make sure that Firefox is not selected to handle PDF files: Firefox > Preferences > Applications

See Firefox repeatedly opens empty tabs or windows after you click on a link

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

http://support.mozilla.com/en-US/kb/Managing+file+types

Which program is set to open PDF files? Not Firefox, needs to be a PDF reader program.

more options

Adobe Reader is already installed. It works in Safari. When Firefox was my default browser, even if Firefox were not open, if I opened a PDF -email attachment, Firefox would open multiples times, etc. and I would have to Force Quit.

more options

Isisombululo Esikhethiwe

Make sure that Firefox is not selected to handle PDF files: Firefox > Preferences > Applications

See Firefox repeatedly opens empty tabs or windows after you click on a link