Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Single word address bar searches resolve with bing search results, not google

  • 37 uphendule
  • 57 zinale nkinga
  • Igcine ukuphendulwa ngu mhorvitz

more options

I've installed all updates recently (win7/x64) apart from Windows Live Essentials.

In firefox (umm... 3.6.3), a single word search in the location bar, eg; "facebook", results in a bing page, not going to, or showing google results like it used to.

Multi-word searches resolve with google.

I don't have any tool bars installed. Google is my default search engine. About:config keywordURL is set to google. "search helper extension" doesn't appear in add-ons, nor does zugo or bing bar. I've disabled all add-ons, restarted. Same result. I started in safe mode Same result.

I've removed bing from IE8, set google as default. There are no toolbars installed.

I've searched my programs list. Nothing mentioned appears, everything seems fine. I looked at recent updates, nothing related to "search". I've looked in program files/program files (x86) for Program Files\Microsoft\Search Enhancement Pack\ but no such folder exists. I searched regedit for "bing", few results, but nothing that seemed linked with FF.

Why is bing showing up? I don't want it, I didn't ask for it, and I can't get rid of it.

This happened

Every time Firefox opened

== not sure. Recently.

All Replies (20)

more options

Same problem is happening on my install on Win 7 32 bit. Recent updates that were installed related to office, .net framework, and activex killbits, a security update to IE, security update for win 7.

I also get sent to bing when typing an address containing a local SMB hostname. (whether an option from the address bars autocomplete is selected or just the hostname typed alone)

My 64 bit desktop does NOT seem to have this problem. Same updates were installed by the desktop (apart from some being the x64 equivalents)

Copying my profile from the desktop does not solve the problem

more options

Same problem but I haven't installed any of the windows updates.

more options

exact same problem. single word entries are redirected to bing. new profile doesn't work. anyone got a solution?

more options

Same problem and I have installed the windows updates.

more options
more options

Hi TXGuy, thanks for your suggestions.

The only new one was uninstalling KB982381. Unfortunately, it hasn't done anything. Single words still end up as bing searches.

I might try uninstalling other updates, but I don't really want to do that.

more options

i have the same problem, and its not only happening in FF. it also happens in opera. i dont have chrome on this pc, but i'm quite sure its also happening there.

my best bet is that m$ messed something up in registry.

damn you micrsoft

more options

i also have the same problem too, i wanna destroy bing!

more options

i hate bing and do not want to use it!

more options

Same problem!

more options
more options

@cor-el i tried b4 it doesn't work. btw iI dont have bing bar installed and no bing in Add-ons

more options

Hi cor-el,

If you read my original message, you'll see I don't have search helper or bing toolbar installed, but thanks for your suggestion.

more options
more options

Thanks cor-el,

Before you post more links, please read my original entry. You'll be able to see what I've already tried.

more options


thanks for telling him, looks like bing or Microsoft downloaded something inside our computer

more options

I'm not able to fix this problem, I hate bing and for all single queries it results to search at bing. I've removed that

more options

Check your "Connection-specific DNS Suffix Search List" (ipconfig /all from a command prompt). If there's an in there, you're going to need to get rid of it. is the default, but now it's redirecting to Bing. (Who approved that idea?)

Pull up your IPv4 properties for whatever interface you're using (under Control Panel\Network and Internet\Network Connections) and under Advanced select "Append these suffixes (in order)". Since it needs a suffix, hit add, and put in a dot. [See screenshot]

There's probably a better way to do this (i.e. not forcing it to use a dummy DNS suffix) but this is pretty foolproof.

Good luck!

more options

That fixed it for me.

But what I don't get is that my desktop (that uses ethernet to the router) does not need this, whereas my laptop (wireless) does...

more options

I posted this to another thread as well: I fixed this by editing the registry. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters and empty the "" value from the ICSDomain key, then disable and re-enable your adapter. I hope that helps. I searched for other instances of "" and "ICSDomain" in the registry and didn't find any so that should do the trick.

  1. 1
  2. 2