Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do you stop AddThis mouse over drop down menu or block AddThis?

  • 5 uphendule
  • 53 zinale nkinga
  • Igcine ukuphendulwa ngu lulgi

more options

Apparently, someone has created a thing called AddThis that can be put into any webpage design. Supposedly, it is to help the reader share the great webpage they've found (or something??). Really, it seems to just be a way for a web designer to attract more page hits.

I find the default setting that causes a rather large (say 5 times larger than icon on the webpage itself) menu to drop down whenever a cursor passes over to be incredibly annoying! If you move your mouse to bring the cursor down the page to reach a link or start to select some text and pass over this AddThis icon, the menu pops down covering a huge area which is often the exact area you are trying to click on. How anyone could think a web surfer would desire this behavor is beyond me.

I am hoping there is a way in FF to stop this kind of behavor. I would like to find a setting or an add-on that could block it altogether (an AdBlock for AddThis).

Any ideas?

== web designers starting adding AddThis to their pages.

Isisombululo esikhethiwe

That is actually part of the website. I'm not sure what can be done to block it. If you right-click on it, and select Adblock Plus: Block image, does that work?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (5)

more options

It's probably one of your add-ons. If you close Firefox, then start Firefox in Safe Mode, does the problem still occur? For instructions on starting in Safe Mode, see Diagnose Firefox issues using Troubleshoot Mode.

more options

Thank you for your reply.

I started FF in Safe Mode and finally found a page with the menu bar thingy. It still dropped down a menu with mouse-over. It is not actually misfunctioning--it is doing what it is designed to do--I just don't like what it does!

The site I looked at is and the bar I am talking about is just left of their search box and has an orange Plus mark and logos for Delicious, Digg and Live. (see screen cap attached)

When you mouse over it, the drop down box has a title bar that says, "Bookmark & Share" and has a close box 'X' on the right. The bottom of the box says "Get Add This for Firefox" and on the right has the orange plus sign with "Add This". This drop down box is what comes up when you mouse over the "bar" and is what I want to stop happening (I would like to block "Add This" totally or at least stop the drop down action on ANY page that I might visit).

From the Add This website, I gather a web designer can simply add this bar to their page and select which things to include (Digg, etc). The default setting is to have the drop down on mouse over. Apparently, the web designer can change the functionality to make the reader have to click once on the bar to activate the drop down. That option, IMO, should be available to the reader!

Is there some way in FF to take back control? Thanks again!

more options

Isisombululo Esikhethiwe

That is actually part of the website. I'm not sure what can be done to block it. If you right-click on it, and select Adblock Plus: Block image, does that work?

more options

That may have worked!

I never noticed that option before as I had never right-clicked on the bar before. There was something about filters so I added one with anything with addthis in the domain name and refreshed the page I mentioned above and the the AddThis bar did not appear again.

This filter may have worked. The AddThis site lists sites that use the button: and I went two a few and couldn't see the AddThis bar so I guess it is filtered out.

Thank you for helping me find an answer!

more options

You can block AdThis completely by using the NoScript plugin.