Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can't add search providers from website and I can't find search providers on the add-ons site

  • 4 uphendule
  • 9 zinale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu cor-el

more options

I'm using Firefox 3.6.3 and I removed the Google search provider (I was trying to figure out how to get it to default to using the new SSL search site), but now I can't re-add Google from their website and when I select the "Get more search engines..." link I get taken to the Firefox Add-Ons site where the searches do not actually return search providers, just plug-ins.

This happened

Every time Firefox opened

== Dunno, this is the first time I've tried to add search providers in Firefox 3.6.3

All Replies (4)

more options

You can restore the default search engines if you click the search engine icon on the Google search bar and open "Manage Search Engines".

Look here for additional search engines: http://mycroft.mozdev.org/ Look here for additional Google search engines: http://mycroft.mozdev.org/quick/google.html


http://kb.mozillazine.org/Unable_to_search_or_add_new_engines http://kb.mozillazine.org/Search_Bar

more options

You can add your own search bar by using https://addons.mozilla.org/en-US/firefox/addon/3682 I use this all the time it is very simple and easy to use

more options

Add Google SSL (still in beta testing) to the search bar (click the first item): http://mycroft.mozdev.org/search-engines.html?name=google+ssl

If you want Google SSL (still in beta testing) to search when typing in the URL/location bar, you need to change a preference, keyword.url: -Enter about:config in the address/URL bar and press the Enter key -If you see a warning, accept it (Promise that you will be careful) -Filter = keyword.url -Below the Filter, right-click on keyword.URL and choose "Modify" -Enter or copy the following into the value field: https://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= -Restart Firefox (File > Restart Firefox)

See: http://kb.mozillazine.org/Keyword.url


Other Issues: to correct security/stability issues

Update Java: your ver. 1.6.0.19; current ver. 1.6.0.20 (important security update 04-15-2010) (Firefox 3.6 and above requires Java 1.6.0.10 and above; see: http://support.mozilla.com/en-US/kb/Java-related+issues#Java_does_not_work_in_Firefox_3_6) (Windows users: Do the manual update; very easy.) See: Updating Java Do the update with Firefox closed.

Install/Update Adobe Flash Player for Firefox: your ver. 10.0 r32; current ver. 10.0 r45 See: Updating Flash -use Firefox to download and SAVE to your hard drive (save to Desktop for easy access) -exit Firefox (File > Exit) -check to see that Firefox is completely closed (Ctrl+Alt+Del, choose Task Manager, click Processes tab, if "firefox.exe" is on the list, right-click "firefox.exe" and choose End process, close the Task Manager window) -double-click on the Adobe Flash installer you just downloaded to install/update Adobe Flash -when the Flash installation is complete, start Firefox, and test the Flash installation here: http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15507&sliceId=1

more options

To add Google back to the search bar, go to http://mycroft.mozdev.org/ , click on "Top 100", Google is #11 on the list.