Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox has suddenly stopped loading any CSS images at all on any websites.

  • 11 uphendule
  • 154 zinale nkinga
  • 5041 views
  • Igcine ukuphendulwa ngu cor-el

more options

I left for a while and my girlfriend used Firefox while I was gone (about 20 minutes). Now that I've come back, Firefox does not load ANY css bg images at all on any sites. I've tried disabling all add-ons and restarting firefox and restarting the computer and clearing the cache and all that good stuff. Settings are not blocking images and are surely loading all image content automatically and all. In fact, according to firebug, css background images are loaded by the browser when i visit sites, they just don't display. safari works fine.

confused.

This happened

Every time Firefox opened

== About an hour ago.

Isisombululo esikhethiwe

See: http://kb.mozillazine.org/Website_colors_are_wrong Website colors are wrong

Firefox > Preferences > Content : Fonts & Colors: Colors > [[X]"Allow pages to choose their own colors, instead of my selections above"

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 5

All Replies (11)

more options

Update -- it's not just css images; it's all css background colors and text colors. Layout is all completely normal, but all colour and background stuff doesn't work (links are all blue, pages all white, etc.).

more options

Isisombululo Esikhethiwe

See: http://kb.mozillazine.org/Website_colors_are_wrong Website colors are wrong

Firefox > Preferences > Content : Fonts & Colors: Colors > [[X]"Allow pages to choose their own colors, instead of my selections above"

more options

I have had the same problem happen. I was copying an image a few days ago and accidentally clicked on something when I right clicked on the image to copy. At that moment all my images were gone. I don't know how to get them back. The page loads as normal just don't have any images.

Please help!

more options

I'm having this problem, but narrowed it down to Firebug. I have "Allow pages to choose their own colors, instead of my selections above" checked, so that's not it. I uninstalled Firebug and reinstalled it and reset all settings, but I still cannot see images on our home page.

more options

Okay, I fixed it, just not sure why this mattered. I just did a Clear Console and the images are now showing.

more options

I am also having this problem. I have tried all solutions mentioned in this thread, but none seem to work. I also use Firebug, but clearing the console does nothing. Neither does uninstalling Firebug. I noticed that in the Firefox Error Console I receive warnings for these issues. For example on this page I see numerous warning like:

Warning: Error in parsing value for 'background-image'. Declaration dropped. Source File: http://support.mozilla.com/en-US/questions/681224?s=css+images&as=s Line: 0

What's interesting is that it seems like this also effects other browser styling like the syntax coloring on the "View Page Source" panel.

I'm using Firefox 3.6.10

more options

Turns out that in the Web Developer Add-on "Disable Page Colors" was somehow set. I wonder if there's a keyboard shortcut for this that was accidentally activated.

more options

I had the same problem I clicked view page source and Ifind out that fire fox is commenting out my css links

   <link href="css/....css" rel="stylesheet" type="text/css" />
   <link href="css/....css" rel="stylesheet" type="text/css" />

... the fire fox 3.6.2 wa commenting out the lines between comments

more options

Can you post a link?

Make sure that there aren't any comment tags that have more than two consecutive hyphens like "---" or unclosed or not properly closed comments.

more options

yes there was more than one hyphens I removed the comments any way thanks

more options

You're welcome