Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to remove redundant english dictionaries (so I don't have 2 Australian dicts., 2 US dicts., and 2 UK dicts.) showing up in the right click menu?

  • 6 uphendule
  • 26 zinale nkinga
  • 1542 views
  • Igcine ukuphendulwa ngu sergiomb

more options

I'm running Ubuntu 9.10. I installed the Spanish (spain) dictionary for OpenOffice using "sudo apt-get install myspell-es" which also invaded firefox and suddenly my right click > languages menu for spell checking is loaded to the nuts with choices of dictionaries for every kind of spanish from cuban to venezuelan.

Moreover, English US and English UK both appear twice. I ran "sudo apt-get remove myspell-es" and the spanish dicts. disappeared, which is good, but how do I remove the redundant australian english, us english, and uk english dictionaries from the right click firefox menu because right now there are 2 of each of those?


This happened

Every time Firefox opened

== I ran sudo apt-get install myspell-es

All Replies (6)

more options

If those dictionaries were installed as part of your Linux distribution then you need to remove via that software installation. If you installed them yourself then uninstall them via Tools > Add-ons > Extensions If you can't uninstall them then disable the ones that you do not want to use.

more options

Actually for Australian, US, and UK I don't have any extensions installed. It's only in Myspell. I went into Synaptic and uninstalled the Australian dictionary. In OpenOffice it disappeared accordingly, but in Firefox not one but both Australian dictionaries disappeared!

When I reinstalled the Australian myspell dictionary, two australian dictionaries reappeared in Firefox!

Why is this happening?

more options

Hi! I've just found a solution:

from: http://ubuntuforums.org/showpost.php?p=5293436&postcount=8

"Make sure Firefox is not running. Go to /usr/lib/firefox-3.0/dictionaries or /usr/lib/firefox/dictionaries, whichever is your case, and remove the .dic and .aff files you do not need. Start Firefox. Enjoy (-:"

Hope it helps!

Antonio

more options

Interesting. I'll remember that location for future reference, but now my immediate problem has been solved because I just removed the Myspell and Hunspell dictionaries (which were creating the duplicates) and just filled in the blanks with Firefox and OpenOffice extensions.

Here's a link to my same question on Ubuntu forums which will offer anyone more background info on this issue: http://ubuntuforums.org/showthread.php?t=1491260

So right now I'm just wonderin why Myspell did that...

more options

Well I've found out what the problem was:

After I installed the Australian English myspell dictionary through Synaptic as a test, I found that (as expected from before) there were now two Australian English entries in Firefox's right-click menu when there should've only been one;

So then I went to /usr/lib/firefox-3.5.9/dictionaries and I found something very peculiar - there were two files named en_AU, one of them being a ".aff" and the other a ".dic" as expected (so en_AU.aff and en_AU.dic), however, there were two more files with those exact names beside them: en_AU.aff and en_AU.dic, and these latter two were links to the former two in the same folder!

This is how both the first set and the duplicate set were able to coexist in the same folder and hence why Firefox created two Australian English (as well as US, UK, etc.) entries!

So that's what the problem was. One question still remains which may not be answered for a long while: why were the duplicate entries created?

Who knows? Maybe it was a bug. Oh well.

more options
  • On Fedora ( may on redhat)
  • ls -l /usr/lib64/xulrunner-2/dictionaries
  • /usr/lib64/xulrunner-2/dictionaries -> /usr/share/myspell
  • ls -l /usr/share/myspell
  • (I got n symbol links)
  • (as root I remove all of symbol link with )
  • cd /usr/share/myspell
  • find -type l -exec rm {} \;
  • Now I just got 3 dictionaries