Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Garbled text when setting "let websites choose their own font" enabled

  • 11 uphendule
  • 28 zinale nkinga
  • 285 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi everyone,

I am on windows XP Sp3, with the latest firefox.

For no good reason, when I have the setting "let websites choose their own font" selected under options/content/fonts and colors/advanced, I see text that looks like this:

http://i4.photobucket.com/albums/y114/brianbotkiller/untitled-1.jpg

This even happens on Firefox's own support page! In fact, I can't even see the text for typing in my issue, if I have the choose own font setting enabled.

So what's going on here? I've uninstalled/reinstalled FF, Disabled all addons, run in safe mode, cleared caches, EVERYTHING, and FF just seems horked. WTF?


URL of affected sites

http://twitter.com

Isisombululo esikhethiwe

This issue can be caused by the bitmap version of the Helvetica or Geneva font or another (bitmap) font that can't be displayed by Firefox in that font size. Firefox can't display that font in the specified size and displays gibberish instead. You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.

Uninstall (remove) all variants of that not working font to make Firefox use another font or find a True type version of that font that doesn't have the problem.

See also http://kb.mozillazine.org/Issues_related_to_fonts#Gibberish

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (11)

more options

I have the exact same problem I have no idea what the deal is. I've tried everything myself. Must just be a bug with the new versions I don't know. They will hopefully fix it or someones needs to tell me how to.

more options

Isisombululo Esikhethiwe

This issue can be caused by the bitmap version of the Helvetica or Geneva font or another (bitmap) font that can't be displayed by Firefox in that font size. Firefox can't display that font in the specified size and displays gibberish instead. You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.

Uninstall (remove) all variants of that not working font to make Firefox use another font or find a True type version of that font that doesn't have the problem.

See also http://kb.mozillazine.org/Issues_related_to_fonts#Gibberish

more options

No offense to Mozilla, who have developed a fine product, but it's a bit insane that those of us who use Helvetica should have to delete it for this product to function. None of the other browsers have that issue, so it couldn't possibly be that difficult to correct. This is a major problem for anyone who does any graphic design. We shouldn't have to choose between functionality and our work.

more options

I agree with wholeheartedly with twrex. Please fix it.

Okulungisiwe ngu Wrenaria

more options

It is caused by using old Mac versions of the Helvetica font. If you only have modern vector type (Open Type, True Type) versions of Helvetica installed then there shouldn't be a problem.

You can try to increase the value of this pref: browser.display.auto_quality_min_font_size (20)

more options

Why would a Windows computer have old Mac fonts installed?

I have the same problem on Windows XP SP3. I've updated Firefox twice since I switched from Internet Explorer 7 and am now using version 3.6.12 and still have the problem. In my case, what I assume are "special symbols" display as an outline rectangle with 2 rows of 2 numbers inside the rectangle. I've used other answers within the support forum to change font size, change the character encoding, not allow the web page to use its own font, etc. So far, those things have not helped.

more options

You seem to be using Unicode (UTF-8) to show that text.

You can try some different Western or Windows encodings or Auto-Detect : Universal to see if that helps.

View > Character Encoding

more options

Making the suggested changes altered what I see, as shown in the attachement, but I still have a problem.

more options

You need to use UTF-8 to display that page and not a Western encoding. Choosing Universal may not detect the encoding correctly in all cases, so you may need to try different encodings on some site if the server doesn't send the correct encoding. It can even make things worse and in such a case Auto-Detect is off is the recommended setting.

What is the default encoding (used when the server doesn't specify one) ?

Tools > Options > Content : Fonts & Colors: Advanced > Default Character Encoding

more options

I was using UTF-8 before and changed it after reading your previous suggestion. The attached will show the settings you questioned.

more options

The page /questions/670622 (How do I get rid of these strange characters) in your above search results image doesn't display well for me. So that is a bad example and you can't get that page display correctly. That (”= %e2%80%9d : ”) looks like that text was copied as Unicode and send as Western encoding by the server and that corrupted the characters.