X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable automatic spell checking on Firefox Mobile?

Kuphostiwe

Hello,

I installed Firefox onto my N900, and its spell checking functionality annoys me very much. I usually type in a language that it doesn't support, and even in English it sometimes underlines words which it doesn't have in its dictionary.

I know all I have to do is set "layout.spellcheckDefault" to 0 in about:config, but I can't do that... double clicking the setting name just zooms in and out, and there is no way to disable it (or I haven't found it) from the Settings UI.

Finally, I did it by manually editing the following file: /home/opt/mozilla/fennec-1.0.0/defaults/preferences/mobile.js

However, in my opinion, a simple solution should be presented for more casual users.

Extensions installed:

Weave Adblock Plus

Hello, I installed Firefox onto my N900, and its spell checking functionality annoys me very much. I usually type in a language that it doesn't support, and even in English it sometimes underlines words which it doesn't have in its dictionary. I know all I have to do is set "layout.spellcheckDefault" to 0 in about:config, but I can't do that... double clicking the setting name just zooms in and out, and there is no way to disable it (or I haven't found it) from the Settings UI. Finally, I did it by manually editing the following file: /home/opt/mozilla/fennec-1.0.0/defaults/preferences/mobile.js However, in my opinion, a simple solution should be presented for more casual users. == Extensions installed: == Weave Adblock Plus

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Eminye Imininingwane

AnonymousUser 405 izisombululo 14878 izimpendulo
Kuphostiwe

Hi Venemo,

You've found a bug! You're right the dialog that comes up in about:config is broken/hard to use. Sorry for your troubles -- an about:config rework is coming that will make this a lot easier. Thanks for pointing this out!

Hi Venemo, You've found a bug! You're right the dialog that comes up in about:config is broken/hard to use. Sorry for your troubles -- an about:config rework is coming that will make this a lot easier. Thanks for pointing this out!
AnonymousUser 405 izisombululo 14878 izimpendulo
Kuphostiwe

Venemo,

This is the relevant bug for your reference: https://bugzilla.mozilla.org/show_bug.cgi?id=540009

Venemo, This is the relevant bug for your reference: https://bugzilla.mozilla.org/show_bug.cgi?id=540009

Umnikazi wombuzo

Caitlin,

Thanks for your answer! Since then, I figured out that I could change those settings in about:config by selecting them and pressing enter.

By the way I installed the nightly Fennec build, and it seems more responsive than the Firefox-named release version. It doesn't support the Adblock plugin, so that may be reason enough to switch back to the 1.0 version.

Caitlin, Thanks for your answer! Since then, I figured out that I could change those settings in about:config by selecting them and pressing enter. By the way I installed the nightly Fennec build, and it seems more responsive than the Firefox-named release version. It doesn't support the Adblock plugin, so that may be reason enough to switch back to the 1.0 version.