Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not load any site

  • Akukho zimpendulo
  • 0 zinale nkinga
  • 1 view
more options

Hi. I just hoped on my computer and firefox seems to not want to load any site. Somehow this support page is the only thing that seems to be working. My other browsers such as Chrome is working perfectly fine, I'm able to search whatever & watch videos no problem so it does not appear to be a wifi issue...

Everything I search on firefox leads to a blank page that doesn't appear to be loading no matter how long I leave it for. The menu button in firefox does not work either

I've tried: - Restarting the computer several times - Turning off Anti-Virus - Clearing cookies & data

I've attached screenshots of what it looks like whenever I try to search for something... Looking to hear of any solutions you may have!

Hi. I just hoped on my computer and firefox seems to not want to load any site. Somehow this support page is the only thing that seems to be working. My other browsers such as Chrome is working perfectly fine, I'm able to search whatever & watch videos no problem so it does not appear to be a wifi issue... Everything I search on firefox leads to a blank page that doesn't appear to be loading no matter how long I leave it for. The menu button in firefox does not work either I've tried: - Restarting the computer several times - Turning off Anti-Virus - Clearing cookies & data I've attached screenshots of what it looks like whenever I try to search for something... Looking to hear of any solutions you may have!
Ama-screenshot ananyekiwe

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.