Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TB won't install after deleting old (corrupt) version

  • 2 uphendule
  • 0 zinale nkinga
  • Igcine ukuphendulwa ngu jfdi

more options

Win 10. Multiple email accounts, some gmail plus others. I had TB 115 something (it's uninstalled so not available to see). I run Firefox without issues. TB went completely haywire, all email accounts disappeared, nothing worked (second time this year) but recovering was proving too difficult and I'd already spent a whole day on it. I decided to uninstall and install a fresh copy. First I copied the single profile to an external drive. Then I uninstalled TB. Then I ran Ccleaner to tidy up the remaining TB cache and other remnants, also cleaned the registry. I downloaded a new copy from Mozilla's site, ran the install file, The install dialog box offers the same install location as the previous location, same user. Upon clicking install, the dialog box disappears and nothing happens. I've tried this more than ten times now, including fresh downloads from Mozilla. The dialog box offers an alternative user as Administrator but that won't work because I don't actually have the administrator account set up with a password, and TB demands the password. I do not want to open a new user account just for TB. Any suggestions for working round this will be gratefully received.

Win 10. Multiple email accounts, some gmail plus others. I had TB 115 something (it's uninstalled so not available to see). I run Firefox without issues. TB went completely haywire, all email accounts disappeared, nothing worked (second time this year) but recovering was proving too difficult and I'd already spent a whole day on it. I decided to uninstall and install a fresh copy. First I copied the single profile to an external drive. Then I uninstalled TB. Then I ran Ccleaner to tidy up the remaining TB cache and other remnants, also cleaned the registry. I downloaded a new copy from Mozilla's site, ran the install file, The install dialog box offers the same install location as the previous location, same user. Upon clicking install, the dialog box disappears and nothing happens. I've tried this more than ten times now, including fresh downloads from Mozilla. The dialog box offers an alternative user as Administrator but that won't work because I don't actually have the administrator account set up with a password, and TB demands the password. I do not want to open a new user account just for TB. Any suggestions for working round this will be gratefully received.

Isisombululo esikhethiwe

Sorry, thrashing around losing track of where I'm at. Thought at first it was a different problem, but now see it as part of the original.

UPDATE - simply closing the dialog box without choosing an option brings up other installation options; TB now installed

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

This is a duplicate of https://support.mozilla.org/en-US/questions/1448392 please keep within the original thread to ensure that volunteers helping you will see the full history. Thanks.

Helpful?

more options

Isisombululo Esikhethiwe

Sorry, thrashing around losing track of where I'm at. Thought at first it was a different problem, but now see it as part of the original.

UPDATE - simply closing the dialog box without choosing an option brings up other installation options; TB now installed

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.