Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

WebGL creation failed after reinstalling lbgl1* libegl*

more options

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02).

I used to play this game named narrow.one, which before I reinstalled the mentioned libraries, was working fine except for crashing a few times. I thought these libraries were causing some issue, so I tried reinstalling them.

I reinstalled the libraries using: `sudo apt install --reinstall --fix-missing libgl1* libegl*`

After installation, I start getting that error. So, I tried reinstalling firefox (using the same command), and then restarting the laptop - but of no use. Chrome seems to be running WebGL, including the game.

In firefox, on the https://get.webgl.org/ page, I see Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

After that, I also tried reinstalling `libopengl0` and `libglu1-mesa` and `intel-microcode`, but of no use. Running although, `sudo intel_gpu_top` and then chrome, it seems that the GPU is in use by chrome as well.

I then go to about:support. It shows me the images I have attached. Reading the logs, there several `blocklisted` values in `Decision Log` section. I suspect that's the cause of this issue, but then I don't know how can I un-blocklist the blocklisted things, and even after that, why does Chrome runs webgl if these are blocklisted?

Running `glxinfo -B`, I get the following: `name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer):

   Vendor: Intel (0x8086)
   Device: Mesa Intel(R) HD Graphics 620 (KBL GT2) (0x5916)
   Version: 23.2.1
   Accelerated: yes
   Video memory: 7697MB
   Unified memory: yes
   Preferred profile: core (0x1)
   Max core profile version: 4.6
   Max compat profile version: 4.6
   Max GLES1 profile version: 1.1
   Max GLES[23] profile version: 3.2

OpenGL vendor string: Intel OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2) OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL core profile shading language version string: 4.60 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL shading language version string: 4.60 OpenGL context flags: (none) OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-1ubuntu3.1 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20`

I do not know much about OpenGL, but reading the above stuff, I suppose my GPU is in use and also has a compatible driver (although I am not sure).

Also, running `glxdemo`, `glxheads`, and `glxgears` seems to be rendering stuff.

Should I reinstall firefox after purging it first? Please help.

Thanks!

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only '''Intel Corporation HD Graphics 620 (rev 02)'''. I used to play this game named [http://narrow.one narrow.one], which before I reinstalled the mentioned libraries, was working fine except for crashing a few times. I thought these libraries were causing some issue, so I tried reinstalling them. I reinstalled the libraries using: `sudo apt install --reinstall --fix-missing libgl1* libegl*` After installation, I start getting that error. So, I tried reinstalling firefox (using the same command), and then restarting the laptop - but of no use. Chrome seems to be running WebGL, including the game. In firefox, on the https://get.webgl.org/ page, I see ''Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.'' After that, I also tried reinstalling `libopengl0` and `libglu1-mesa` and `intel-microcode`, but of no use. Running although, `sudo intel_gpu_top` and then chrome, it seems that the GPU is in use by chrome as well. I then go to about:support. It shows me the images I have attached. Reading the logs, there several `blocklisted` values in `Decision Log` section. I suspect that's the cause of this issue, but then I don't know how can I un-blocklist the blocklisted things, and even after that, why does Chrome runs webgl if these are blocklisted? Running `glxinfo -B`, I get the following: `name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer): Vendor: Intel (0x8086) Device: Mesa Intel(R) HD Graphics 620 (KBL GT2) (0x5916) Version: 23.2.1 Accelerated: yes Video memory: 7697MB Unified memory: yes Preferred profile: core (0x1) Max core profile version: 4.6 Max compat profile version: 4.6 Max GLES1 profile version: 1.1 Max GLES[23] profile version: 3.2 OpenGL vendor string: Intel OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2) OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL core profile shading language version string: 4.60 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL shading language version string: 4.60 OpenGL context flags: (none) OpenGL profile mask: compatibility profile OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-1ubuntu3.1 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20` I do not know much about OpenGL, but reading the above stuff, I suppose my GPU is in use and also has a compatible driver (although I am not sure). Also, running `glxdemo`, `glxheads`, and `glxgears` seems to be rendering stuff. Should I reinstall firefox after purging it first? Please help. Thanks!
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

All Replies (6)

more options

I think that the main reason is that you're using Webrender (Software). Try to set gfx.webrender.all to true and gfx.webrender.software to false in about:config.

Okulungisiwe ngu TyDraniu

Helpful?

more options

TyDraniu said

I think that the main reason is that you're using Webrender (Software). Try to set gfx.webrender.all to true and gfx.webrender.software to false in about:config.

Thanks, but setting those value (gfx.webrender.software was already false) does not help.

Searching related gfx options, there are these three modified:

  1. gfx.webrender.all true
  2. gfx.webrender.software.d3d11 false
  3. services.settings.blocklists.gfx.last_check 1713968137

This is also there, but unmodified:

  1. gfx.blocklist.all 0

Helpful?

more options

One error I forgot to mention earlier was: * GL error 0x502 occurred during OpenGL context initialization, before WebGL initialization! (FEATURE_FAILURE_WEBGL_GLERR_1)

As it says, WebGL is not being initialized. What does that mean? Does WebGL need to be initialized at system level or application level?

Thanks!

Helpful?

more options

Isisombululo Esikhethiwe

Does it still happen with the flatpak package?

Helpful?

more options

zeroknight said

Does it still happen with the flatpak package?

I will try to install the flatpak version (and also purging this apt installation and then reinstalling firefox).

I can't confirm the results currently, since I do not have access to my laptop right now. Please do not mind the delay :)

Helpful?

more options

Although I was able to install firefox via flatpak and use it without any error, still I wanted to give a try to the apt version.

I reinstalled the apt version after purging, then also refreshed firefox (I suppose I had ticked all the options when it asked me which stuff to save).

This time, I tried running firefox from the terminal. This is the output:

> firefox

   ATTENTION: default value of option mesa_glthread overridden by environment.
   [GFX1-]: Failed to compile vertex shader: gpu_cache_update
   
   [ERROR webrender::device::gl] Failed to compile vertex shader: gpu_cache_update
   
   [GFX1-]: wr_window_new: Shader(Compilation("gpu_cache_update", ""))
   [GFX1-]: Failed to connect WebRenderBridgeChild. isParent=true
   [GFX1-]: Fallback WR to SW-WR

I have seen https://support.mozilla.org/en-US/questions/1437760; but I think I am using the current stable version from apt only. Maybe, it is related to some library which I need to reinstall?? Here is what apt says firefox's deps are:

   libasound2, libatk1.0-0, libc6, libcairo-gobject2, libcairo2, libdbus-1-3, libfontconfig1, libfreetype6, libgcc1, libgdk-pixbuf2.0-0, libglib2.0-0, libgtk-3-0, libpango-1.0-0, libpangocairo-1.0-0, libstdc++6, libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxcomposite1, libxcursor1, libxdamage1, libxext6, libxfixes3, libxi6, libxrandr2, libxrender1

I will try reinstalling the graphic libraries from the ones listed above.

Although, I am not sure if the library(ies) are the problem, and not some sort of firefox configuration. I'll be thankful if someone looks at the firefox's output and can find anything!

Thanks!

Okulungisiwe ngu Lakshay Rohila

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.