Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"About Firefox" box shows error message "Failed to check for updates".

more options

I have a macbook pro running Sonoma 14.2.1. A few days ago I noticed the computer didn't update to the current version of Firefox when I attempted to do so after being prompted that an update was available. I went to "About Firefox" and saw the error message "Failed to check for updates". Please help. Thanks.

I have a macbook pro running Sonoma 14.2.1. A few days ago I noticed the computer didn't update to the current version of Firefox when I attempted to do so after being prompted that an update was available. I went to "About Firefox" and saw the error message "Failed to check for updates". Please help. Thanks.

All Replies (7)

more options

Hi William, your Firefox reported itself to be the current version, so you are up-to-date.

As for why one specific update check failed, assuming everything else was working, I couldn't say for sure. Possibly the update check server was not available or too busy at that time?

If your Firefox can never find updates, its access might be blocked by a firewall/hosts file rule or by a policy.

Helpful?

more options

Thank you for your reply. The failed to check for updates error message problem has been on-going for several days. I have the current Firefox version because I went to the Mozilla page and downloaded it manually.

Helpful?

more options

You can check for an anti-update policy by typing or pasting about:policies in the address bar and pressing Enter/Return to load the page. The "Active" section normally says "The Enterprise Policies service is inactive." Does yours list any active policies?

You can check for modified update URLs this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are checking for customizations, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste app.update.url and pause while the list is filtered

(3) If the preferences are bolded, indicating a non-default value, you can click the Reset button at the right end of the row to restore the default URLs

Helpful?

more options

You can check the connection settings in case you use a Proxy or VPN service.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a Proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

more options

About:policies returns "The Enterprise Policies service is inactive." Typing about:config, then app.update.url did not produce any bolded results. Only saw app.update.url manual and app.update.url.details.

Helpful?

more options

Proxy settings is set to "Use system proxy settings."

Helpful?

more options

WILLIAM RAMIREZ said

Proxy settings is set to "Use system proxy settings."

You could change that to No Proxy, assuming you do not intentionally use a proxy server.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.