Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Websites don't work with FireFox but do with other browsers

  • 8 uphendule
  • 1 inale nkinga
  • 8 views
  • Igcine ukuphendulwa ngu jonzn4SUSE

more options

I've written about this before and never got a working answer. I have to use Chrome or internet explorer for some work because FireFox won't open the sites. This problem hasn't been fixed by I clearing cache and cookies as recommended back when I first asked a year or so ago.

Now the latest website I haven't been able to use is the Post office! USPS.com -- If I try to track a mail piece using my tracking number the site can't bring it up. The site tries for long time then tells me to try later. When I try with another browser such as Chrome, the result is there within a couple of seconds. It looks like I'm going to have to leave FireFox which I hate as I've used it so long - over ten years at least.

Version 121 Windows 10

I've written about this before and never got a working answer. I have to use Chrome or internet explorer for some work because FireFox won't open the sites. This problem hasn't been fixed by I clearing cache and cookies as recommended back when I first asked a year or so ago. Now the latest website I haven't been able to use is the Post office! USPS.com -- If I try to track a mail piece using my tracking number the site can't bring it up. The site tries for long time then tells me to try later. When I try with another browser such as Chrome, the result is there within a couple of seconds. It looks like I'm going to have to leave FireFox which I hate as I've used it so long - over ten years at least. Version 121 Windows 10

All Replies (8)

more options

Did you try Firefox in 'Safe Mode'?

I found an old USPS tracking email and it works for me wit a Load Time 829 ms. see screenshot

Helpful?

more options

Yes. I'm sure it does. Same thing happened last time I tried to get help for Firefox. Many people say they tried and it works for them. Doesn't solve my issue. Thanks anyway.

Helpful?

more options

See image of what I get after a few minutes...

Helpful?

more options

What security software are you running? Windows home or pro? If pro try this option and see if you have the same issue. https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/

Helpful?

more options

MS included windows security and Malwarebytes

Helpful?

more options

Disable Malwarebytes, reboot, and try again.

Helpful?

more options

I'll give that a try later and see if it solves problem and post if it does. Tks

Helpful?

more options

We'll leave the light on for ya.  ;-))

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.