Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Corrupted local mailbox Thunderbird 115.5 Windows 10

  • Akukho zimpendulo
  • 0 zinale nkinga
  • 8 views
more options

The problem is a badly corrupted local mailbox. I'm using Thunderbird 115.5.0 (upgrading when it asks), on Windows 10 64-bit. I'm using gmail (imap.gmail.com). To keep gmail and my profile inbox (on my system SSD) manageable in size, I've been moving a month of mail at a time to a local folder on a hard drive. Sometimes that fails, and sometimes it takes a while (like an hour) to move the month of mail (typically 5000 messages) from All Mail to the local folder (e.g. Local Folders / 2022 / November .) Once they all look to be moved I've deleted that month's mail from All Mail and compacted it. Sometimes that takes a while (a couple of days.) Sometimes the move stops, and I start over. I wanted to reference an email from last year. (Black Friday offer from a particular vendor.) The local folder shows a lot of messages with no subject, correspondents is blank (dash) and the date is when I did the move. I found the messages I wanted with Filter. Some are good, some appear blank, or to have random pieces of other mail. When I looked at the mbox folder things were still corrupt. I moved 2 of the blank messages to a new subfolder. In an editor I could make out something, and Thunderbird still showed the original subject. I removed the .msf folder and that didn't help. I did Properties | Repair Folder and the mailbox became 0 size.

As an experiment I copied a random message to the subfolder. I can see the subject in Thunderbird (Garlic lovers, don't miss this deal!), and it looks good, but when I open the body I see XML and no body text or images. In the folder I have

From - Tue Nov 21 01:19:38 2023 X-Mozilla-Status: 0001 X-Mozilla-Status2: 00000000 X-Mozilla-Keys: nonjunk Dleft style=3D"font-size:0;padding:5px 10px 5px 10px;word-break:=

and a little further down

Received: from [10.98.212.170] ([10.98.212.170:43868] helo=r223.subs.subway.com) by momentum01.lon7.cpt.adobe.net (envelope-from <bounce@subs.subway.com>) (ecelerity 4.2.31.59853 r(Core:4.2.31.1)) with ESMTP id B3/13-01767-2AE96436; Wed, 12 Oct 2022 12:01:54 +0100 From: "SUBWAY Restaurants" <news@subs.subway.com> Subject: =?windows-1252?Q?Garlic_lovers=2C_don=92t_miss_this_deal!?= Date: Wed, 12 Oct 2022 12:01:54 +0100 To: < --me-- >

Also in the process of messing around, a bunch of messages get duplicated.

Can I fix this corruption? How can I avoid the mailboxes become corrupt? Is it wrong to do what started, moving a month of mail from All Mail to a local folder, then deleting those messages from All Mail?

The problem is a badly corrupted local mailbox. I'm using Thunderbird 115.5.0 (upgrading when it asks), on Windows 10 64-bit. I'm using gmail (imap.gmail.com). To keep gmail and my profile inbox (on my system SSD) manageable in size, I've been moving a month of mail at a time to a local folder on a hard drive. Sometimes that fails, and sometimes it takes a while (like an hour) to move the month of mail (typically 5000 messages) from All Mail to the local folder (e.g. Local Folders / 2022 / November .) Once they all look to be moved I've deleted that month's mail from All Mail and compacted it. Sometimes that takes a while (a couple of days.) Sometimes the move stops, and I start over. I wanted to reference an email from last year. (Black Friday offer from a particular vendor.) The local folder shows a lot of messages with no subject, correspondents is blank (dash) and the date is when I did the move. I found the messages I wanted with Filter. Some are good, some appear blank, or to have random pieces of other mail. When I looked at the mbox folder things were still corrupt. I moved 2 of the blank messages to a new subfolder. In an editor I could make out something, and Thunderbird still showed the original subject. I removed the .msf folder and that didn't help. I did Properties | Repair Folder and the mailbox became 0 size. As an experiment I copied a random message to the subfolder. I can see the subject in Thunderbird (Garlic lovers, don't miss this deal!), and it looks good, but when I open the body I see XML and no body text or images. In the folder I have From - Tue Nov 21 01:19:38 2023 X-Mozilla-Status: 0001 X-Mozilla-Status2: 00000000 X-Mozilla-Keys: nonjunk Dleft style=3D"font-size:0;padding:5px 10px 5px 10px;word-break:= and a little further down Received: from [10.98.212.170] ([10.98.212.170:43868] helo=r223.subs.subway.com) by momentum01.lon7.cpt.adobe.net (envelope-from <bounce@subs.subway.com>) (ecelerity 4.2.31.59853 r(Core:4.2.31.1)) with ESMTP id B3/13-01767-2AE96436; Wed, 12 Oct 2022 12:01:54 +0100 From: "SUBWAY Restaurants" <news@subs.subway.com> Subject: =?windows-1252?Q?Garlic_lovers=2C_don=92t_miss_this_deal!?= Date: Wed, 12 Oct 2022 12:01:54 +0100 To: < --me-- > Also in the process of messing around, a bunch of messages get duplicated. Can I fix this corruption? How can I avoid the mailboxes become corrupt? Is it wrong to do what started, moving a month of mail from All Mail to a local folder, then deleting those messages from All Mail?

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.