Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefix automatically reverting back to NON incognito

  • 3 uphendule
  • 6 zinale nkinga
  • 83 views
  • Igcine ukuphendulwa ngu gatehealing

more options

I ALWAYS use FF in incognito mode. I do not ever switch to non incognito. However, after closing FF (iphone14 pro max, all fully updated) for a couple of hours, when I open, it’s magically back on NONincognito mode.

Also, when in incognito mode, FF still keeps cookies after I have deleted them and cleared caches.

I ALWAYS use FF in incognito mode. I do not ever switch to non incognito. However, after closing FF (iphone14 pro max, all fully updated) for a couple of hours, when I open, it’s magically back on NONincognito mode. Also, when in incognito mode, FF still keeps cookies after I have deleted them and cleared caches.

All Replies (3)

more options

Here are some steps and considerations to address these problems:

Check Privacy Settings:

Ensure that your privacy settings in Firefox are configured correctly. To do this:
  • Open Firefox on your iPhone.
  • Tap the three horizontal lines in the bottom menu to access the menu.
  • Scroll down and tap on "Settings."
  • Under "Privacy," make sure "Always use private browsing" is enabled.
  • Force Close and Reopen Firefox:
  • If you find that Firefox occasionally reverts to non-incognito mode, it could be a glitch. To address this, try force closing the app and reopening it:

Check for iOS Updates: Make sure your iPhone's operating system is also up to date. Apple frequently releases iOS updates that may contain bug fixes and improvements.

Cookies in Incognito Mode: Regarding cookies persisting in incognito mode, it's worth noting that Firefox's private browsing mode is designed not to store your browsing history, search history, or cookies after you close it. However, it's possible that some websites may employ techniques to bypass these restrictions. Make sure you're using the latest version of Firefox, as newer versions often have enhanced privacy features.

Report the Issue: If the problems persist, consider reporting the issue to Mozilla, the organization behind Firefox. They may be able to provide further guidance or address the issue in future updates.

Helpful?

more options

1) There is no “always use private browsing.” If it is a bot that is replying to me, it needs to be updated with current information. See screenshot.

2) I have force closed, updated Firefox, updated iPhone, deleted and reinstalled Firefox, turned on the off again the “close private tabs when leaving private browsing” (I believe this is the setting you are referring to in number 1 above.

3) How do I report this to Mozilla? I would’ve started there if I knew that was an option.

Thanks.

(What is the “needs more information from user” checkbox below this text box where I am currently typing? I’m the user so I’m not sure why I’d check this? See screenshot).

Helpful?

more options

This continues to happen, but now it is not intermittent…it is reverting every time I re-open Firefox if it has been closed for a few hours.

How do I fix this? As I said before, everything is up to date, I’ve taken all steps you suggested, and more multiple times to no effect.

Are you working on a fix or is this just happening to me (in which case I just stop using Firefox, at least for 3-6 months to give time for this to be resolved)?

Still not sure whether I need to check the “need more info” box under this text field.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.