Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video Playback Issue on Fedora 38 - "Media Playback Aborted due to Corruption"

more options

I'm encountering consistent video playback issues on Firefox while running Fedora 38. The error message I receive when attempting to play videos from certain sites, notably LinkedIn and Twitter (now X), is:

  • The media playback was aborted due to a corruption problem or because the media used features your browser did not support.*

Furthermore, when examining Firefox's console while attempting to play a video, I observed the following error:

  • [Child 5999, MediaDecoderStateMachine #1] WARNING: Decoder=7fdb3c55a100 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<60>::InitDecoder(AVDictionary**): Couldn't open avcodec: file /builddir/build/BUILD/firefox-118.0/dom/media/MediaDecoderStateMachineBase.cpp:166*

Steps to Reproduce: 1. Navigate to LinkedIn or X (previously Twitter). 2. Attempt to play any video content. 3. Observe the aforementioned error.

Additional Details: - OS: Fedora 38 - Firefox version: Initially 117.0.1, then updated to 118, both 64-bit. - This issue does not occur on Google Chrome on the same system. - I have attempted the following troubleshooting steps without success:

 1. Updated Firefox to the latest version.
 2. Enabled DRM content.
 3. Booted Firefox in Safe Mode.
 4. Disabled hardware acceleration.
 5. Cleared cache and cookies.
 6. Used a Flatpak version of Firefox.

This issue has significantly impacted my user experience, and I hope to find a resolution soon. Any assistance or guidance would be greatly appreciated.

Thank you!

I'm encountering consistent video playback issues on Firefox while running Fedora 38. The error message I receive when attempting to play videos from certain sites, notably LinkedIn and Twitter (now X), is: *The media playback was aborted due to a corruption problem or because the media used features your browser did not support.* Furthermore, when examining Firefox's console while attempting to play a video, I observed the following error: *[Child 5999, MediaDecoderStateMachine #1] WARNING: Decoder=7fdb3c55a100 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<60>::InitDecoder(AVDictionary**): Couldn't open avcodec: file /builddir/build/BUILD/firefox-118.0/dom/media/MediaDecoderStateMachineBase.cpp:166* Steps to Reproduce: 1. Navigate to LinkedIn or X (previously Twitter). 2. Attempt to play any video content. 3. Observe the aforementioned error. Additional Details: - OS: Fedora 38 - Firefox version: Initially 117.0.1, then updated to 118, both 64-bit. - This issue does not occur on Google Chrome on the same system. - I have attempted the following troubleshooting steps without success: 1. Updated Firefox to the latest version. 2. Enabled DRM content. 3. Booted Firefox in Safe Mode. 4. Disabled hardware acceleration. 5. Cleared cache and cookies. 6. Used a Flatpak version of Firefox. This issue has significantly impacted my user experience, and I hope to find a resolution soon. Any assistance or guidance would be greatly appreciated. Thank you!

All Replies (9)

more options

Make sure you have the latest FFmpeg and libavcodec packages installed.

Helpful?

more options

RPM Fusion repo:

sudo dnf install ffmpeg


Flatpak:

flatpak install org.freedesktop.Platform.ffmpeg-full

Helpful?

more options

I have exactly the same problem, using the environment:

  • Fedora 38
  • Firefox 117.0.1 stable, Flatpak version

I can't open videos from my Synology Photos. Looking at the console, I get the following error: ``` Media resource https://<my_nas_server>/123 could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) Details: mozilla::MediaResult mozilla::FFmpegDataDecoder<60>::InitDecoder(): Couldn't open avcodec ```

And I already have the `ffmpeg` DNF package and the `org.freedesktop.Platform.ffmpeg-full` version 23.08 flatpak.

Note: Testing here, the `ungoogled-chromium` flatpak works just fine. My guess is that Firefox (flatpak version) have some misconfiguration related other flatpak dependencies, like the `org.freedesktop.Platform.ffmpeg-full`.

Okulungisiwe ngu Luiz Felipe F M Costa

Helpful?

more options

Luiz Felipe F M Costa said

`org.freedesktop.Platform.ffmpeg-full` version 23.08 flatpak.

The Firefox flatpak currently uses the 22.08 runtime, so you will need to install the corresponding version of org.freedesktop.Platform.ffmpeg-full.

Helpful?

more options

@zeroknight thanks for the answer.

I just tried. I restarted the browser and it didn't work.

Helpful?

more options

Can you play the same videos in a non-flatpak installation?

Helpful?

more options

@zeroknight yep. It works just fine, despite the following warns:

``` [Child 156982, MediaDecoderStateMachine #1] WARNING: 7f101e2ae3a0 OpenCubeb() failed to init cubeb: file /builddir/build/BUILD/firefox-118.0.1/dom/media/AudioStream.cpp:281 [Child 156982, MediaDecoderStateMachine #1] WARNING: Decoder=7f0e0162e000 [OnMediaSinkAudioError]: file /builddir/build/BUILD/firefox-118.0.1/dom/media/MediaDecoderStateMachine.cpp:4649 ```

- Mozilla Firefox 118.0.1 (installed via dnf)

Helpful?

more options

(I accidentally repeated this post)

Okulungisiwe ngu Luiz Felipe F M Costa

Helpful?

more options

(I accidentally repeated this post too)

Okulungisiwe ngu Luiz Felipe F M Costa

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.