Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Bing becomes default browser and I don't have access to Add-ons and Themes

more options

For the last few days I have had a problem that Bing becomes my default search engine. Even when I go to Google.com it will still reroute to Bing. I searched the forums for solutions and none worked. I couldn't even get into Add-ons and Themes. I would just get a blank page.


Resolution: Finally I decided the best way to deal with this is to delete and re-install Firefox. I saved my Bookmarks first. Then I went to install/uninstall and went to uninstall Firefox, but it gave me another option when I hit it to Refresh Firefox. I chose that option and it reset Firefox to all default/original settings. I didn't even have to import Bookmarks as it kept them and 2 of the Add-ons that I use were optioned to reinstall. The only thing I ended up doing was adding the Menu Bar back on and adding a home page button under Customize Toolbar.

Hope this helps others.

For the last few days I have had a problem that Bing becomes my default search engine. Even when I go to Google.com it will still reroute to Bing. I searched the forums for solutions and none worked. I couldn't even get into Add-ons and Themes. I would just get a blank page. Resolution: Finally I decided the best way to deal with this is to delete and re-install Firefox. I saved my Bookmarks first. Then I went to install/uninstall and went to uninstall Firefox, but it gave me another option when I hit it to Refresh Firefox. I chose that option and it reset Firefox to all default/original settings. I didn't even have to import Bookmarks as it kept them and 2 of the Add-ons that I use were optioned to reinstall. The only thing I ended up doing was adding the Menu Bar back on and adding a home page button under Customize Toolbar. Hope this helps others.
Ama-screenshot ananyekiwe

All Replies (1)

more options

Thank you for your report.

For future reference if the problem returns:

The most likely culprit is a malicious add-on. When an add-on blocks address to the Add-ons page, you usually need to restart in Troubleshoot Mode to disable all extensions so they can't interfere. See: Diagnose Firefox issues using Troubleshoot Mode.

If you are curious what add-ons you had installed before:

Refresh creates a folder on your Windows desktop named "Old Firefox Data" and moves your old profile folder there. In that folder will be a file named extensions.json that you can view in a Firefox tab. I also have a page on my website that generates a more readable table from that file if you can't tease out the relevant data from the built-in JSON viewer: https://www.jeffersonscher.com/ffu/extensionsjson.html