Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

keyboard in Firefox wrong input for all keys

  • 7 uphendule
  • 4 zinale nkinga
  • 205 views
  • Igcine ukuphendulwa ngu Paul

more options

For some reason all of a sudden Firefox doesn't register the correct inputs from my keyboard, i don't know if i accidentally changed a setting or what. No matter what letter, number, or symbol i press on my keyboard, no matter what text field on any website as long as its firefox, all it will output is a rotating set of " 1234567890-=qwertyuiop[]asdfghjkl;'`\zxcvbnm,./-+\ " in that order regardless of what key i press with the exception of functional keys which still work normally.

To be clear, what happens is for example i press the letter "t" once, the output says "q" i press "t" again it outputs "w" i press "t" again, this time it outputs "e" all the way down the line until i get back to i press "t" and get "q". It doesn't matter if i press a sequence of different letters all presses are registered as a "next letter" command and i get the next letter in the sequence output is always 1234567890-=qwertyuiop[]asdfghjkl;'`\zxcvbnm,./-+\

I tried starting Firefox in troubleshoot mode and it had the same issue, i looked through settings for some kind of accessibility or language option that i was unfamiliar with to see if i enabled something by mistake but i couldn't find anything. All other programs on my computer work normally, other internet browsers work normally, Firefox works normally as long as i don't have to type anything, but y'know, its kind of hard to use a program if you have to copy paste text out of a notepad document every time you want to search for something.

For some reason all of a sudden Firefox doesn't register the correct inputs from my keyboard, i don't know if i accidentally changed a setting or what. No matter what letter, number, or symbol i press on my keyboard, no matter what text field on any website as long as its firefox, all it will output is a rotating set of " 1234567890-=qwertyuiop[]asdfghjkl;'`\zxcvbnm,./-+\ " in that order regardless of what key i press with the exception of functional keys which still work normally. To be clear, what happens is for example i press the letter "t" once, the output says "q" i press "t" again it outputs "w" i press "t" again, this time it outputs "e" all the way down the line until i get back to i press "t" and get "q". It doesn't matter if i press a sequence of different letters all presses are registered as a "next letter" command and i get the next letter in the sequence output is always 1234567890-=qwertyuiop[]asdfghjkl;'`\zxcvbnm,./-+\ I tried starting Firefox in troubleshoot mode and it had the same issue, i looked through settings for some kind of accessibility or language option that i was unfamiliar with to see if i enabled something by mistake but i couldn't find anything. All other programs on my computer work normally, other internet browsers work normally, Firefox works normally as long as i don't have to type anything, but y'know, its kind of hard to use a program if you have to copy paste text out of a notepad document every time you want to search for something.

Isisombululo esikhethiwe

My ZoneAlarm client was as up to date as it could be, so i contacted Support and they told me to just uninstall the anti-keylogger feature. Evidentally the AKL is installed separately from the rest of ZoneAlarm, after uninstalling it Problem solved. Thanks for the help everyone.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

What security software do you have as this might be about scrambling the keyboard input for safely what doesn't seems work in Firefox?

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Boot the computer in Windows Safe Mode with network support to see if that has effect.

more options

You can try to disable the ZoneAlarm anti-keylogger feature.

more options

Hi, i tried everything you suggested except check userChrome.css/userContent.css. Nothing worked except booting my computer in safe mode. Zonealarm's anti-keylogger has been disabled for months.

more options

It must be bug 1847033. Try to update ZoneAlarm.

more options

Yes, try updating ZoneAlarm as they may have fixed their random keyboard inputs issue as it did for one user in https://support.mozilla.org/en-US/questions/1420073#answer-1594933

more options

Isisombululo Esikhethiwe

My ZoneAlarm client was as up to date as it could be, so i contacted Support and they told me to just uninstall the anti-keylogger feature. Evidentally the AKL is installed separately from the rest of ZoneAlarm, after uninstalling it Problem solved. Thanks for the help everyone.

more options

Hi

Thank you for your patience while we have been looking into this issue. We have issued an update to Firefox that is expected to fix this problem. Please make sure that you have version 116.0.2 of Firefox installed on your device.

For help updating, please see: https://support.mozilla.org/en-US/kb/update-firefox-latest-release#

Thank you.