Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

UI Text Changes Color (Greys Out) When Firefox Window Loses Focus

  • 9 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu Anthony

more options

After updating to Firefox 115.0-1, I noticed that the tab names for all inactive tabs automatically greys out whenever the main Firefox window loses focus (see attached gif image). Only the system theme is affected. I should also note that only Firefox 115 exhibits this behavior (downgrading to Firefox 114.0.2-1 fixes the issue).

I'm not sure if this is by design. I've gone through the change log for Firefox 115 and found no mentions of this.

Of course, the behavior isn't that big of a deal. However, since I'm using a window manager (i3wm), an annoying "flash" (see attached gif image) can be observed every time I press a keybinding to activate a binding mode.

If this is a new feature, I'd very much like to turn it off in about:config.

Does anyone know how?

After updating to Firefox 115.0-1, I noticed that the tab names for all inactive tabs automatically greys out whenever the main Firefox window loses focus (see attached gif image). Only the system theme is affected. I should also note that only Firefox 115 exhibits this behavior (downgrading to Firefox 114.0.2-1 fixes the issue). I'm not sure if this is by design. I've gone through the change log for Firefox 115 and found no mentions of this. Of course, the behavior isn't that big of a deal. However, since I'm using a window manager (i3wm), an annoying "flash" (see attached gif image) can be observed every time I press a keybinding to activate a [https://i3wm.org/docs/userguide.html#binding_modes binding mode]. If this is a new feature, I'd very much like to turn it off in about:config. Does anyone know how?
Ama-screenshot ananyekiwe

Okulungisiwe ngu Anthony

All Replies (9)

more options

I'm not seeing that issue. For testing, you should try a different window manager. Are you in X11 or Wayland? What OS? Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release


Operating System: openSUSE Tumbleweed 20230703 KDE Plasma Version: 5.27.6 KDE Frameworks Version: 5.107.0 Qt Version: 5.15.10 Kernel Version: 6.3.9-1-default (64-bit) Graphics Platform: X11 Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz Memory: 125.1 GiB of RAM Graphics Processor: Mesa Intel® UHD Graphics 630 Manufacturer: HP Product Name: HP ZBook 17 G6

more options

Hello, thank you for the response.

I'm on X11. (OS: EndeavourOS, WM: i3, kernel: 6.4.1-arch2-1)

I'm currently using the latest firefox version from the Arch repository.

jonzn4SUSE said

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

I've already tried this. The issue is also present in Mozilla's binary release.

Edit: Running firefox on different gtk themes yielded the same behavior.

Okulungisiwe ngu Anthony

more options

jonzn4SUSE said

I'm not seeing that issue. For testing, you should try a different window manager. Are you in X11 or Wayland? What OS? Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release Operating System: openSUSE Tumbleweed 20230703 KDE Plasma Version: 5.27.6 KDE Frameworks Version: 5.107.0 Qt Version: 5.15.10 Kernel Version: 6.3.9-1-default (64-bit) Graphics Platform: X11 Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz Memory: 125.1 GiB of RAM Graphics Processor: Mesa Intel® UHD Graphics 630 Manufacturer: HP Product Name: HP ZBook 17 G6

It's surprising that you weren't able to reproduce it. I can even reproduce it on a live ISO using a different desktop environment (XFCE).

FF 115 is on the left whereas FF 114 is on the right. As you can see, the tab names (on the left window) greys out every time the window loses focus.

Okulungisiwe ngu Anthony

more options

I'm observing the same behavior in Firefox 115 with Fluxbox. Very annoying. Also menu and tabs background color is changed: https://support.mozilla.org/en-US/questions/1417606 I hope it is possible somehow to get back the old behavior and colors, at least with third-party theme but without patching and rebuilding Firefox from sources.

more options

dimich.dmb said

I'm observing the same behavior in Firefox 115 with Fluxbox. Very annoying. Also menu and tabs background color is changed: https://support.mozilla.org/en-US/questions/1417606 I hope it is possible somehow to get back the old behavior and colors, at least with third-party theme but without patching and rebuilding Firefox from sources.

Using a third party theme solves the issue, at least temporarily. As far as I know, only the "system default" theme is affected by this.

more options

Interesting... If you're having the same issue with your distro version and Mozilla, it sounds like time to test in another OS. wink wink See if you have the same issue on that hardware with another OS like openSUSE live ISO for example?  ;-)) https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-XFCE-Live-x86_64-Current.iso

more options

jonzn4SUSE said

Interesting... If you're having the same issue with your distro version and Mozilla, it sounds like time to test in another OS. wink wink See if you have the same issue on that hardware with another OS like openSUSE live ISO for example?  ;-)) https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-XFCE-Live-x86_64-Current.iso

Just out of curiosity. Did you switch your firefox theme to 'system-default' first before testing the issue? I'm saying this because the behavior only occurs when system-default theme is enabled.

more options

I was on the system theme, but since the 114 update they (Mozilla) have messed up with the dark theme you see in my screenshot, but I still do not have your issues.

more options

jonzn4SUSE said

I was on the system theme, but since the 114 update they (Mozilla) have messed up with the dark theme you see in my screenshot, but I still do not have your issues.

Yeah, I see.

This might have to do with the GTK theme being used. Some GTK themes grey out the UI text for inactive windows and some don't. In versions prior to 115, the tab names won't change colors regardless of whether the FF window is active. Starting from 115, tab name colors for system theme seem to follow the underlying gtk theme. I happen to use a gtk theme that greys out text whenever windows go inactive. For the time being, I managed to get rid of this annoying issue by loading a third-party firefox theme. Honestly, I'm not even sure if the devs will even bother to fix this.

P/S: And I certainly agree with what you said about the dark theme. It looks hideous.

Okulungisiwe ngu Anthony