Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do you block automatic video play?

  • 1 baphendule
  • 0 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu cor-el

more options

Hi

Automatic video play has been quite a nuisance in spite of using some recommended measures, such as under Firefox Settings => Privacy and Security => Permissions => Autoplay => both options set to Block Video & Audio and saving. The settings change does not appear to work.

Since I mostly use the Portableapps.com version of Firefox, I suspected it might be the issue, after noting once you restart Firefox, that the settings are both back to = Allow Video & Audio! I immediately checked out a separate standalone Firefox installation which I updated to 114.0 (64-bit), but to my dismay, noticed it does also not keep the preferred "Block Video and Audio" settings, also when the browser is restarted.

So is there a bug in the Windows versions I use on my Win 10 64bit and if not, which would be strange, what is going on, why are the settings not kept and how can effectively stop auto-play, which can be a nuisance.

An example of such videos is on Huffpost, such as https://www.huffpost.com/entry/jake-tapper-brianna-keilar-cnn-gop-race_n_647ece5ce4b0b4444c80b001 where the DeSantis video immediately loads and starts playing. The Settings save does not appear to work at all.

Thank you for you help.

Hi Automatic video play has been quite a nuisance in spite of using some recommended measures, such as under Firefox Settings => Privacy and Security => Permissions => Autoplay => both options set to Block Video & Audio and saving. The settings change does not appear to work. Since I mostly use the Portableapps.com version of Firefox, I suspected it might be the issue, after noting once you restart Firefox, that the settings are both back to = Allow Video & Audio! I immediately checked out a separate standalone Firefox installation which I updated to 114.0 (64-bit), but to my dismay, noticed it does also not keep the preferred "Block Video and Audio" settings, also when the browser is restarted. So is there a bug in the Windows versions I use on my Win 10 64bit and if not, which would be strange, what is going on, why are the settings not kept and how can effectively stop auto-play, which can be a nuisance. An example of such videos is on Huffpost, such as https://www.huffpost.com/entry/jake-tapper-brianna-keilar-cnn-gop-race_n_647ece5ce4b0b4444c80b001 where the DeSantis video immediately loads and starts playing. The Settings save does not appear to work at all. Thank you for you help.
Ama-screenshot ananyekiwe

All Replies (1)

more options

You can look at these prefs on the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.block-autoplay-until-in-foreground

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.