Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

New Tabs

  • 5 uphendule
  • 0 zinale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu cor-el

more options

When I open a new tab this website opens up instead of a blank tab. "https://search.rspark.com/?ytm"

I've set my new tabs to open a blank page, and I have the current version.

When I open a new tab this website opens up instead of a blank tab. "https://search.rspark.com/?ytm" I've set my new tabs to open a blank page, and I have the current version.
Ama-screenshot ananyekiwe

All Replies (5)

more options

First thought is you have some malicious app or software on your device. - Check your FireFox extensions / try opening FireFox in safe mode - Check other apps on your device.

more options

I know I don't have any malicious apps or software on my mac. This only started when I went to Mozilla to update my Firefox to the latest version. After I did the download and placed the new version into my applications and then opened the file everything looked okay until I create a "NEW" tab that's when this page comes up. I don't think it's on my end, I did what I was suppose to do and downloaded the NEW version and then this happens. I don't like to get angry and upset about this but I think it's on your end not mine. I keep my mac up to date as much as I can, being that it is an older iMac, but none the less, I don't visit malicious websites or download anything from websites that I don't know. It has to be on your end, maybe a "trojan horse" infected the latest version of Firefox for mac. Don't know what else to do except quit using Firefox and use Chrome, don't like using Chrome, it's a hassle but if I cannot get this fixed then I'll have to delete Firefox from my system.

more options

It's possible that one of your add-ons detects the new tab page and replaces it with the unwanted page. Could you test in Firefox's Troubleshoot Mode? Start that up using either:

  • "3-bar" menu button > Help > Troubleshoot Mode...
  • (menu bar) Help menu > Troubleshoot Mode...

and OK the restart. A small dialog should appear. Click the Open button.

Any improvement?

You didn't share your extensions list while posting your question, so here's how to check for problem extensions on your Firefox:

Open the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions the new tab, search, or privacy, or looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement after you quit Firefox and start it back up normally (i.e., not in Troubleshoot mode)?

more options

I see you reported this in February after updating to Firefox 110.

Another method someone might use to override the new tab page is a startup script, also known as an Autoconfig file. I know where to look for those on Windows, but I'm less familiar with Mac. The help article "Customizing Firefox Using AutoConfig" refers to the "Contents/Resources directory of the Firefox.app". Does that mean anything to you? If not, we probably should get a Mac person to chime in on where exactly to look.

One thing you could check in the interim requires the Browser Console (Command+Shift+J). If you have not used its command line before, there is a setup step:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste devtools.chrome.enabled and pause while the list is filtered

(3) Double-click the preference (or click the toggle button at the right end of the row) to switch the value from false to true

Next, open the Browser Console using Command+Shift+J. It should have various messages and a command entry area, which typically starts with a double right angle bracket (»).

To see whether Firefox is using a script-assigned new tab page, type or paste

AboutNewTab.newTabURLOverridden

and press return (or click the Run button, if it appears) to review the returned value.

If Firefox reports true then this likely is the source of your problem. To reset the URL to a blank page, type or paste

AboutNewTab.newTabURL = 'about:newtab';

and press return (or click the Run button, if it appears).

This should cause Firefox to use your setting from the Preferences page. However, how long that change will be in effect depends on how "rspark" is changing your page in the first place.

more options

Note that AboutNewTab.newTabURL is a setter and getter, so merely typing/pasting AboutNewTab.newTabURL in the Browser Console gives the current new tab page setting (no need to press the Enter key).