Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox snap app does not recognize custom cursor.

  • 2 uphendule
  • 1 inale nkinga
  • 511 views
  • Igcine ukuphendulwa ngu cor-el

more options

I can't get Firefox to use some custom cursors. Firefox is only recognizing the cursors that came installed with Ubuntu. Any of the cursors I installed will default to DMZ-White, but Firefox is using those cursors that came installed with Ubuntu. I tried defining the default cursor in /usr/share/icons/default/index.theme but did nothing as well. Also I tried with the cursor in /usr/share/icons and in /home/name/.icons and firefox cannot get in any of those.

I don't know if it's something wrong with my cursors or it's some inner thing with Firefox, any one has a guess? Incompatibility or something missing from the cursor?

I can't get Firefox to use some custom cursors. Firefox is only recognizing the cursors that came installed with Ubuntu. Any of the cursors I installed will default to DMZ-White, but Firefox is using those cursors that came installed with Ubuntu. I tried defining the default cursor in /usr/share/icons/default/index.theme but did nothing as well. Also I tried with the cursor in /usr/share/icons and in /home/name/.icons and firefox cannot get in any of those. I don't know if it's something wrong with my cursors or it's some inner thing with Firefox, any one has a guess? Incompatibility or something missing from the cursor?

Isisombululo esikhethiwe

Snap has restrictions for what directories are allowed and you probably need to whitelist a specific file path or place the file in allowed locations.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Sounds like a snap issue. https://forum.snapcraft.io/

Try downloading Firefox from Mozilla, run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

Isisombululo Esikhethiwe

Snap has restrictions for what directories are allowed and you probably need to whitelist a specific file path or place the file in allowed locations.

more options

I installed Firefox from a debian package, and the cursors worked as they should. Probably it's the snap package fault.

edit: Reference for what I did: https://askubuntu.com/questions/1399383/how-to-install-firefox-as-a-traditional-deb-package-without-snap-in-ubuntu-22

Okulungisiwe ngu tisppereira