Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

High CPU usage while typing in URL (address) bar

  • 4 uphendule
  • 0 zinale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu FF_Gnome

more options

Hello.

Typing anything in URL (address) bar causes my CPU spike to 15-20% shown in Windows Task Manager, and up to 80% shown in Firefox Task Manager. I have 8 core / 16 threads CPU running at 4.0 GHz, so typing text in browser taking 15-20% of that is rather bizarre to me. OS: Windows 10 What I tried: - disabling Firefox Accessibility Service - hardware acceleration on/off - troubleshooting mode

Don't have same issue in other browsers (Chrome, Opera) Any ideas what else that might be?

Hello. Typing anything in URL (address) bar causes my CPU spike to 15-20% shown in Windows Task Manager, and up to 80% shown in Firefox Task Manager. I have 8 core / 16 threads CPU running at 4.0 GHz, so typing text in browser taking 15-20% of that is rather bizarre to me. OS: Windows 10 What I tried: - disabling Firefox Accessibility Service - hardware acceleration on/off - troubleshooting mode Don't have same issue in other browsers (Chrome, Opera) Any ideas what else that might be?

All Replies (4)

more options

While you type in the address bar, Firefox can be doing any or all of the following:

  • asking your default search engine for search suggestions
  • looking for matches in your bookmarks
  • looking for matches in your browsing history
  • looking for matches in your search history
  • looking for matches among your open tabs
  • (in some regions) looking up suggestions via a Mozilla web service or local file

You can turn these different types of suggestions on/off and see whether you can link the problem to a particular type of suggestion. More info in this article:

Address bar autocomplete suggestions in Firefox -- click into the "How can I control what results the address bar shows me?" section

Any difference?

more options

Thank you for the reply. I have tried just that: disabled search engines and all suggestions from address bar. Unfortunately, no difference: typing in address bar still causes CPU usage to spike to 15%

more options

Hmm, what else could it be?

Could you try changing the setting in the "Speculative pre-connections" section of this article to prevent anticipatory connections (not that these should use much CPU, but ??): How to stop Firefox from making automatic connections.

Also, if turning off browsing history suggestions didn't also disable the in-URL-bar autofill behavior, there is a separate preference for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.urlbar.autoFill and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

more options

Thank you for more suggestions. Sadly, they did not help either.