Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox takes ~1 minute to load pages after window appears.

  • 2 uphendule
  • 0 zinale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu cor-el

more options

Title. Whenever I open Firefox, the window will appear shortly after, but it will take around a minute for websites to load. This applies to both tabs from older sessions and opening new tabs. It doesn't matter whether I've just booted up, or if I've been running for half an hour. I've tried disabling all extensions, but that hasn't fixed anything. I am running Linux Mint 21.1 Cinnamon on my Gaming Laptop. Specs shouldn't be an issue. ANY HELP WOULD BE MUCH APPRECIATED!

Title. Whenever I open Firefox, the window will appear shortly after, but it will take around a minute for websites to load. This applies to both tabs from older sessions and opening new tabs. It doesn't matter whether I've just booted up, or if I've been running for half an hour. I've tried disabling all extensions, but that hasn't fixed anything. I am running Linux Mint 21.1 Cinnamon on my Gaming Laptop. Specs shouldn't be an issue. ANY HELP WOULD BE MUCH APPRECIATED!

Isisombululo esikhethiwe

You already tried with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Do you have the same issue under a different user account on this computer? Did you clear browser cache? https://support.mozilla.org/en-US/kb/how-clear-firefox-cache Who are using for DNS? Lexus of Japan took 3.44 seconds for me to load. see screenshot How long does it take for you?



Operating System: openSUSE Tumbleweed 20230118 KDE Plasma Version: 5.26.5 KDE Frameworks Version: 5.102.0 Qt Version: 5.15.8 Kernel Version: 6.1.6-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

Isisombululo Esikhethiwe

You already tried with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Do you have the same issue under a different user account on this computer? Did you clear browser cache? https://support.mozilla.org/en-US/kb/how-clear-firefox-cache Who are using for DNS? Lexus of Japan took 3.44 seconds for me to load. see screenshot How long does it take for you?



Operating System: openSUSE Tumbleweed 20230118 KDE Plasma Version: 5.26.5 KDE Frameworks Version: 5.102.0 Qt Version: 5.15.8 Kernel Version: 6.1.6-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

more options

You can try to start Firefox via a terminal window and check what messages are displayed.

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.