Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Newsletter unsubscription doesn't seem to work

  • 6 uphendule
  • 0 zinale nkinga
  • 16 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello,

In my newsletter subscription options, I did NOT checked the "Firefox Account Tips" option but I keep receiving mail saying this : "You're receiving this email because [edited] @gmail.com has a Firefox account and is subscribed to Firefox Account Tips."

Could you please fix this issue so that I don't receive these mails anymore ?

Thank you in advance,

Mikael

Hello, In my newsletter subscription options, I did NOT checked the "Firefox Account Tips" option but I keep receiving mail saying this : "You're receiving this email because [edited] @gmail.com has a Firefox account and is subscribed to Firefox Account Tips." Could you please fix this issue so that I don't receive these mails anymore ? Thank you in advance, Mikael
Ama-screenshot ananyekiwe

Okulungisiwe ngu James

All Replies (6)

more options

Did you click unsubscribe option? One those sites get's your email firefox has no control how they send newsletter out-even when you unchecked the box your email is stored on their site. It's best to click unsubscribe to remove it as last resort.

Helpful?

more options

Dropa said

Did you click unsubscribe option? One those sites get's your email firefox has no control how they send newsletter out-even when you unchecked the box your email is stored on their site. It's best to click unsubscribe to remove it as last resort.

This setting is on the Manage your Email Preferences page for your Firefox Account. Firefox is a web browser as the company is Mozilla.

Helpful?

more options

I clicked many times on "Unsubscribe" in the mail and saved my preferences several times with no box selected but it doesn't work at all... (I've sent you a screenshot showing the unselected checkbox and yes, I've also clicked on "Save Preferences")

I finally used the unsubscribe option in my Gmail inbox and I hope I will stop receiving these mails, but the problem is that I've never agreed to receive these mails at first so you should not enable this option by default on a new Firefox account sign up.

In your explanation, what are "those sites" ? They should never have had my email... And anyway, the mails I received were only sent by Firefox <firefox@email.mozilla.org>. So if I uncheck the checkbox, Firefox should not send me any unwanted mails. Is it not as simple as that ?

Regards,

Mikael

Helpful?

more options

It is that simple but evidently not for Mozilla.

Helpful?

more options

I have the same problem. I also get the mozilla account tips spam. I clicked the unsubscribe link and went to the Manage your Email Preferences page. I made sure every option was unchecked and clicked save preferences, but the damned emails keep coming. I can't help but wonder if this is a bug in their system or some elitist Bay area tech type who thinks he/she/it knows better than we do what emails we need to get.

Helpful?

more options

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.