Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Back button doesn't work, only changes the URL

  • 4 uphendule
  • 0 zinale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu Jani

more options

Hello there! I have a strange issue where only the URL changes when I press the back button, it seems to happen randomly, but it isn't only happening to me, I was in a discord call yesterday when I saw it happen for my friend too. See attached gif for an example. Any idea what could cause this, or how to fix it? I haven't found any other threads about this, but I haven't looked very hard.

Hello there! I have a strange issue where only the URL changes when I press the back button, it seems to happen randomly, but it isn't only happening to me, I was in a discord call yesterday when I saw it happen for my friend too. See attached gif for an example. Any idea what could cause this, or how to fix it? I haven't found any other threads about this, but I haven't looked very hard.
Ama-screenshot ananyekiwe

All Replies (4)

more options

When you are not in an input area then the backspace button (including Shift+Backspace) can act differently and browse the Tab history. There is a pref on the about:config page to control this.

  • about:config => browser.backspace_action
0 goes Back/Forward
1 act like PgUp/PgDown
2 and other values, nothing

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

Helpful?

more options

I'm sorry, but I don't get how the backspace button has to do anything with this. If you check the GIF you can see me use the back and forward buttons on my mouse a few times, then the buttons up top. Are the buttons in the UI somehow linked to the backspace_action? Thanks.

Helpful?

more options

I think that I got confused because you wrote press the back button as pressing a key ussualy is done on the keyboard as you would click a button with the mouse. What is going on in your GIF image is hard for me to see as the details are quite small.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

I have already tried on a fresh install of Firefox, seems to be happening regardless of extensions and themes. Also I'm sorry for the small size of the gif, but this was the only way to upload it as the original file was too big. Plus it doesn't happen all the time, so it is hard to pin it on one extension (or anything really), but fortunately (or unfortunately) it is happening on a fresh copy too, so that rules out the possibility of an extension or theme issue (at least in my mind). I will check in with my friend who also has this issue, maybe we can find something.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.