Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't enable USB Devices about:debugging

  • 6 uphendule
  • 0 zinale nkinga
  • 315 views
  • Igcine ukuphendulwa ngu cor-el

more options

I can't enable USB Devices on about:debugging setup page. I already installed ADB toolkit for MacOS, also I can see my device in ADB devices list: ``` ~% adb devices -l List of devices attached 013db356 device usb:336723968X product:OnePlus6T model:ONEPLUS_A6010 device:OnePlus6T transport_id:9 ```

On the device I've enabled "Remote debugging via USB". But when I click on "Enable USB Devices" button, nothing happens. I can see only "Updating..." message, then "Disabled" again.

Also no devices in the devices list, because USB Devices are disabled. "Refresh devices" does not make any changes.

I can't enable USB Devices on about:debugging setup page. I already installed ADB toolkit for MacOS, also I can see my device in ADB devices list: ``` ~% adb devices -l List of devices attached 013db356 device usb:336723968X product:OnePlus6T model:ONEPLUS_A6010 device:OnePlus6T transport_id:9 ``` On the device I've enabled "Remote debugging via USB". But when I click on "Enable USB Devices" button, nothing happens. I can see only "Updating..." message, then "Disabled" again. Also no devices in the devices list, because USB Devices are disabled. "Refresh devices" does not make any changes.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Solved: https://discourse.mozilla.org/t/cant-enable-usb-devices-about-debugging/107823/5

It needs to change the preference “devtools.remote.adb.extensionURL” to https://ftp.mozilla.org/pub/labs/devtools/adb-extension/#OS#/adb-extension-latest-#OS#.xpi in about:config (basically remove the /mozilla.org from the current value).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Ok, your post says iOS but your screenshot says Android? So which one is it? I think you need to contact the Developer of that software you using for more help on it's setup and why it's not working.

Okulungisiwe ngu Dropa

more options

I assume that you have read the docs and possibly did "Refresh devices" ?

Probably best is to take this to the Discourse Devtools forum.

more options

Dropa сказал(а)

Ok, your post says iOS but your screenshot says Android? So which one is it? I think you need to contact the Developer of that software you using for more help on it's setup and why it's not working.

MacOS, not iOS. Firefox on MacOS and mobile Firefox on Android. Also, the problem not on Android, it's on Firefox Browser on MacOS. I can't enable USB Devices. The button does nothing.

Okulungisiwe ngu snakedoc.md

more options

cor-el сказал(а)

I assume that you have read the docs and possibly did "Refresh devices" ? Probably best is to take this to the Discourse Devtools forum.

Yes, I have read the docs, and did "Refresh Devices"

more options

Isisombululo Esikhethiwe

Solved: https://discourse.mozilla.org/t/cant-enable-usb-devices-about-debugging/107823/5

It needs to change the preference “devtools.remote.adb.extensionURL” to https://ftp.mozilla.org/pub/labs/devtools/adb-extension/#OS#/adb-extension-latest-#OS#.xpi in about:config (basically remove the /mozilla.org from the current value).

more options

Note that there has been a bug report created to look into this issue.

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)