Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent Thunderbird from displaying attached mhtml in body of message.

  • 4 uphendule
  • 0 zinale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu Dandelion

more options

I often save web pages in mhtml format and send them to e-mail recipients.

One thing that irks me no end is that Thunderbird insists on displaying the mhtml page in the body of my e-mail, inevitably totally screwing up the formatting and making my e-mail practically illegible.

My work-around has been to put the mhtml into a zip file to prevent this from happening. But the last time I did this, the recipient was unable to open the zip file. It seems to me there ought to be something in Settings that will allow me to prevent Thunderbird from inserting an attachment into the body of my e-mail. An attachment is an attachment. It should not automatically insert itself into the body of my e-mail text.

Is there a way to do this?

Thank you,

Dandelion

I often save web pages in mhtml format and send them to e-mail recipients. One thing that irks me no end is that Thunderbird insists on displaying the mhtml page in the body of my e-mail, inevitably totally screwing up the formatting and making my e-mail practically illegible. My work-around has been to put the mhtml into a zip file to prevent this from happening. But the last time I did this, the recipient was unable to open the zip file. It seems to me there ought to be something in Settings that will allow me to prevent Thunderbird from inserting an attachment into the body of my e-mail. An attachment is an attachment. It should not automatically insert itself into the body of my e-mail text. Is there a way to do this? Thank you, Dandelion
Ama-screenshot ananyekiwe

All Replies (4)

more options

This was discussed earlier: https://support.mozilla.org/en-US/questions/1306090

but I don't know if mail.inline_attachments.text is false (default) or true in your Config. editor. Also, does changing the composition format to plain text allow attachments without showing them inline? If the default format is html, hold Shift when starting a new message to format in plain text.

Helpful?

more options

Talk about a senior moment! I'd completely forgotten that I had already posed this question two years ago.

I figured out that if I went under "View," and removed the check mark next to "Display Attachments Inline," I could prevent Thunderbird from embedding my attachments into the body of the e-mail. So that problem is solved.

But during my experimentation with various settings, I did something that I am unable to reconstruct, which now has caused all my font formatting to disappear. In other words, if I underline or bold the text, or change its color, even though it displays correctly in my composition page, when I send the e-mail, the text formatting has been stripped. Try as I might, I cannot find what I did to cause this.

Could some kind soul please let me know what I have to do to undo what I did and retain my text formatting and not have it converted to asterisks when I view the sent message?

Oh, and as a footnote, it took me forever to figure out how to find the Config Editor in Advanced Options settings. It's not anything like accessing "about: config" in Chrome. Next time you erroneously take for granted that someone knows how to access this setting, it would be helpful if you could supply instructions.

Thanks,

Dandelion

Helpful?

more options

Do you have View/Message Body As set to Original HTML? If not, does changing to that improve the text formatting?

Config. editor is easily found by typing editor in the Settings 'Find in Settings' box.

Helpful?

more options

Hi Sfhowes,

Yep, I did finally figure out that by putting the check mark back to "Original HTML" I could get my text formatting back.

Finding that Config Editor opens up a whole new world to me. It is bound to come in handy at some point, so thanks for drawing my attention to its existence.

I would not have had to post this a second time had one of my recipients not complained that when I stuck my attachments into a zip file, she found she was unable to unzip it. That's why I needed to stop Thunderbird from embedding attachments into the body of my message for once and for all.

Thanks again for your assistance,

Dandelion

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.