Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop New Tab Autoplay

  • 8 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu lonestarnot

more options

How to force Firefox stop autoplaying videos when I'm switching to the i.e. new YouTube tab, but in the same time do not pause a next video on YouTube playlist. Some time ago it worked well, but now if I set Block Audio or\and Video in settings, I have to manually click Play, and with Allow Audio and Video chosen it starts playing video immediately after I click on another tab.

How to force Firefox stop autoplaying videos when I'm switching to the i.e. new YouTube tab, but in the same time do not pause a next video on YouTube playlist. Some time ago it worked well, but now if I set Block Audio or\and Video in settings, I have to manually click Play, and with Allow Audio and Video chosen it starts playing video immediately after I click on another tab.

All Replies (8)

more options

They play as long as you have them open you must pause or stop them. I know I done this before and tabs with each open will play simultaneously unless the user pauses or one ends. Also you need to provide screenshot of that setting so others can verify it with their settings to be sure something else is over-riding it.

Helpful?

more options

Which settings from config do you want to see?

Helpful?

more options

r.bayda said

Some time ago it worked well, but now if I set Block Audio or\and Video in settings, I have to manually click Play, and with Allow Audio and Video chosen it starts playing video immediately after I click on another tab.

You just mentioned it here that is why I asked what settings did you do and to give a screenshot of that change.

Helpful?

more options

That's the point, I did nothing and it've changed by itself. It worked smoothly and as I wanted: autoplay's working and at the same time if I CTRL+Click on the new video to open it in the new tab and then switch to that tab, the video is paused.

Then (I believe after some Firefox update, current version is 106.0.2 x64), autoplay was still working but the new tab started playing the moment I switch to it. I've changed the media.autoplay.default config property to 5 (Settings -> Privacy -> Permissions -> Autoplay -> Block Audio and Video does the same) and both YouTube and new tab autoplay stopped working.

What do I want to achieve: 1. Allow autoplay on YouTube when the first video ends and the next starts. 2. Do not unpause video when I switch to the new tab.

As I've remarked, it worked perfectly some time ago with default settings and now it's not. What should I do to solve my issue?

In addition, I've tried to mix different settings with properties provided in answer here, but the one that have helped at least in some way was media.autoplay.default config, but it didn't solved my issue.

Okulungisiwe ngu SomeOne

Helpful?

more options

Hi

Does this support article help?:

https://support.mozilla.org/en-US/kb/block-autoplay

Helpful?

more options

Paul said

Hi Does this support article help?: https://support.mozilla.org/en-US/kb/block-autoplay

No. 1. Allow audio and video makes YouTube autoplay work properly, but new tab starts playing immediately. 2. Block audio and\or video — both have the same behaviour and block YouTube and new tab autoplay.

Again, how I want it to work (as it was before): 1. YouTube video ends -> next video starts and is not paused. 2. CTRL+Click on a video to open it in a new tab -> tab opens and video is paused -> switch the tabs and the video is still paused until I click Play.

Helpful?

more options

Bump. Anyone, any idea?

Helpful?

more options

Thanks Paul. I think my issue was similar to what SomeOne cited. I often open several URLs/tabs from a query hit-list before going thru each tab to see which video looks most promising. Stopping autoplay annoyingly slowed the visual triage of splash pages I do before committing to selected serial video streams.

After setting "Block Audio and Video" as shown in https://support.mozilla.org/en-US/kb/block-autoplay I can now click through tabs, prioritizing & closing, before diving into the most promising.

Okulungisiwe ngu lonestarnot

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.