Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Version 102.3 - invisible folders and messages

  • 10 uphendule
  • 1 inale nkinga
  • 41 views
  • Igcine ukuphendulwa ngu Toad-Hall

more options

Greetings. My Thunderbird for Windows auto-updated to 102.3. I'm sorry, but I have no idea what the previous version was but it was working fine. Now when I run it newly auto-updated, I am not able to see my four e-mail accounts on the left (all IMAPs) and therefore any message. My accounts are still there and the software is still fetching e-mails and showing new e-mail notifications as normal. I just can't see anything in the main menu. Attached is what it looks like on my end. I have tried restarting my computer and also downloading/installing/running the 64-bit software rather than the 32-bit. Any ideas would be appreciated as it is cutting into my personal productivity right now. Thank you for your time.

Greetings. My Thunderbird for Windows auto-updated to 102.3. I'm sorry, but I have no idea what the previous version was but it was working fine. Now when I run it newly auto-updated, I am not able to see my four e-mail accounts on the left (all IMAPs) and therefore any message. My accounts are still there and the software is still fetching e-mails and showing new e-mail notifications as normal. I just can't see anything in the main menu. Attached is what it looks like on my end. I have tried restarting my computer and also downloading/installing/running the 64-bit software rather than the 32-bit. Any ideas would be appreciated as it is cutting into my personal productivity right now. Thank you for your time.

Isisombululo esikhethiwe

The 'local.sqlite' file seems to be a 'read-only' file.

check that file:

  • Menu icon > Help > More Troubleshooting Information
  • Under 'Application Basics' - half way is Profile Folders - click on 'Open Folder' (Windows OS)

window opens showing contents of your profile name folder

  • Exit Thunderbird now - this is important
  • click on 'calendar-data' folder to see contents.
  • Right click on 'local.sqlite' file and select 'Properties'

On 'General' tab, it will say 'Attributes' at the bottom. Is the 'read-ony' checkbox selected ?

  • If yes, select it to uncheck it.
  • Click on 'Apply'
  • Click on 'OK'

Restart Thunderbird using the 'Run as Admin'

Please report back on results.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (10)

more options

Check you have this setting:

  • 'View' > 'Folders' > 'All'

Then do this:

  • Menu icon > Help > More Troubleshooting Information
  • Under 'Application Basics' - half way is Profile Folders - click on 'Open Folder'

window opens showing contents of your profile name folder

  • Exit Thunderbird now - this is important

Scroll down and delete the following files:

  • folderCache.json
  • folderTree.json
  • virtualFolders.dat
  • session.json
  • xulstore.json

Click on 'Mail' folder

  • delete 'smart mailboxes' folder

Start Thunderbird.

If this fixes your problem please mark as Chosen Solution. Please Report back on results.

Helpful?

more options

Thank you Toad-Hall. I followed all your steps (note: View-->Folders-->All was not checked when I found it).

For the Mail folder, I do not have a "smart mailboxes" folder, only "Local Folders." So I was unable to do the delete smart mailboxes folder step.

I just tried running Thunderbird again and I still have the same issue. Thank you for any possible additional idea.

-Richard

Helpful?

more options

This might sound a bit odd but I have had someone fix a missing account purely because the smtp setting had gone awol.

Each mail account should have it's own outgoing smtp. Menu icon > 'Account Settings' In Left Pane - scroll down to the bottom and click on 'Outgoing Server (SMTP)' It will display the list of outgoing smtp servers and there should be one for each mail account. Start at the top of the list and work down.

select smtp server in list and click on 'Edit' Description : type in the email address - it should be same one as shown in the User Name. Check all the other settings are correct and click on OK Please repeat this for all your list of smtp servers.

If you are missing an smtp server for a particular email address, click on 'Add' and enter the smtp server details.

Now make sure each mail account/email address is actually using the correct smtp. Work from the top down. In Left Pane: select name of account and look bottom right for the Outgoing Server SMTP This is where the description field helps - do you see the same email address as the account name you selected. If no, - click on the drop down selection and choose the correct one. DO NOT click on 'Edit SMTP Server' button because it is likely you will edit something which is set up for another account.

Repeat for next mail account.

When all mail accounts are set up correctly using their own correct outgoing server ... Exit Thunderbird - wait a few moments to allow background processes to complete and then start Thunderbird and report on results.

Helpful?

more options

Thank you again Toad-Hall. Unfortunately, no, SMTP settings do not seem to be the cause. I delete two e-mail accounts I no longer use. There are three accounts I do use and all are correctly configured.

I just realized in my Update History that the last successful version of Thunderbird I used was actually 91.13.1. I guess the software jumped up to 102.3. I attempted to roll back, but now my profile will only work with a newer version so I am a bit stuck at the moment because I need the saved e-mails in my local folder.

Edit - looking at the Thunderbird releases history, the next non-beta release from 91.13.1 was 102.0. So I attempted 102.0. I have the issue as described in the OP, but it accepts my profile. So something happened between those two versions that broke my ability to see my folders.

Okulungisiwe ngu BFBullpup

Helpful?

more options

Tools > Developer Tools > Error console Do you see a load of issues with 'calendar' ? If yes: 1. Post an image of the error console in this question. 2. then Clear the 'Error console' and close the window.

Now do this: 3.

  • Menu icon > Help > More Troubleshooting Information
  • Under 'Application Basics' - half way is Profile Folders - click on 'Open Folder' (Windows OS)

In a Mac it may be called 'Open Finder' In Linux it may be called 'Open directory'

window opens showing contents of your profile name folder

  • Exit Thunderbird now - this is important
  • click on 'calendar-data' folder to see contents.

The file called 'local.sqlite' has all calendar stuff.

  • Please rename the 'local.sqlite' as 'local.sqlite.old'
  • Click on 'backup' folder

You should see a file called 'local.v22.sqlite'

  • Copy the 'local.v22.sqlite' file
  • go back up to the 'calendar-data' folder
  • paste the 'local.v22.sqlite' file into the 'calendar-data' folder
  • then rename the 'local.v22.sqlite' file as 'local.sqlite'

Start Thunderbird. Please report back on results

Helpful?

more options

Are you using Windows 10 or 11 ? I have some reports where you need to start Thunderbird in this way the first time.

Right click on Thunderbird shortcut icon and select 'Run as Administrator'

Helpful?

more options

Thank you for the new suggestions. First off, running as admin did not solve my issue.

I have just re-opened Thunderbird as admin and posted the error message window.

Now I have followed the instructions to copy/paste the local.sqlite file, re-opened as admin, and unfortunately I still get the same result. I hope the attached error console image gives another idea to try. Thank you very much!!!

Helpful?

more options

Isisombululo Esikhethiwe

The 'local.sqlite' file seems to be a 'read-only' file.

check that file:

  • Menu icon > Help > More Troubleshooting Information
  • Under 'Application Basics' - half way is Profile Folders - click on 'Open Folder' (Windows OS)

window opens showing contents of your profile name folder

  • Exit Thunderbird now - this is important
  • click on 'calendar-data' folder to see contents.
  • Right click on 'local.sqlite' file and select 'Properties'

On 'General' tab, it will say 'Attributes' at the bottom. Is the 'read-ony' checkbox selected ?

  • If yes, select it to uncheck it.
  • Click on 'Apply'
  • Click on 'OK'

Restart Thunderbird using the 'Run as Admin'

Please report back on results.

Helpful?

more options

That was it! I appreciate all the troubleshooting; no way I would have thought of it on my own. I don't think I did anything intentionally to make the file read-only. Thank you very much, Toad-Hall!!!

Helpful?

more options

Great news. Glad to hear you are up and running again.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.