Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Colors in panes on Windows 7 Pro.

  • 23 uphendule
  • 1 inale nkinga
  • 23 views
  • Igcine ukuphendulwa ngu dlsmith50076

more options

When Thunderbird upgraded to one of the latest versions (102), it changed the background colors on the folder and message list panes to black with white text, and I cannot get it to change back to white background with black text. The The message display pane is normal black text on white background. What do I have to do to get my correct colors back and why did you change them? I am running Aero on Windows 7 Pro.

When Thunderbird upgraded to one of the latest versions (102), it changed the background colors on the folder and message list panes to black with white text, and I cannot get it to change back to white background with black text. The The message display pane is normal black text on white background. What do I have to do to get my correct colors back and why did you change them? I am running Aero on Windows 7 Pro.
Ama-screenshot ananyekiwe

Okulungisiwe ngu Wayne Mery

All Replies (20)

more options

It may be that theme was changed. Try tools>addons and select themes. The one you want is the Light theme.

Helpful?

more options

The theme didn't change, as soon as the update installed, it changed the colors. Any theme except for the Light and System themes cause the panes to go black. Tries several other themes too, and get the same results. Something in TB broke the theme colors.

Helpful?

more options

I could be wrong, but I believe Aero is no longer supported

Helpful?

more options

Aero is disabled on my computer.

Helpful?

more options

dlsmith50076 said

Aero is disabled on my computer.

But your screen shot does suggest Aero is enabled, and you earlier stated "I am running Aero on Windows 7 Pro."

Anyway, * Please start *Windows'* in safe mode with networking enabled win10 https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode

  • Still in Windows safe mode, start Thunderbird in Troubleshoot mode

https://support.mozilla.org/en-US/kb/troubleshoot-mode-thunderbird

Does problem go away?

-- Start *Windows'* safe mode with networking enabled

- win7 https://support.microsoft.com/en-us/help/17419/windows-7-advanced-startup-options-safe-mode#start-computer-safe-mode=windows-7

Still In Windows safe mode, do Help > Troubleshoot mode

Does problem go away?

Helpful?

more options

I don't know why I said that, I must have meant something else. No, I am not running an Aero theme, and changing it to a standard Windows 7 theme doesn't cure the problem.

Regardless, why would TB display the proper colors in the message content pane, but not in the folder and message list pane? Obviously, there is a problem in the coding for the pane colors.

I'm not going to stop using TB over this, I just can't imagine I'm the only one that this is affecting.

Thanks for your help.

Helpful?

more options

I neglected to include the screen shots of TB in Windows Safe Mode, the problem persists, but goes away in TB troubleshoot mode.

Helpful?

more options

Screenshot on Windows Safe Mode.

Helpful?

more options

I am a bit confused. In one of your responses, you indicate that the colors go black in other than the light or system theme. That comment indicates that the screen has white background and black text when the light theme is selected. True? If not, please clarify. On your question about the message pane, that is set at tools>general and the 'colors' button. On that, please check and verify that the box for 'use system colors is NOT ticked.

Helpful?

more options

Are you using any addons that may affect the theme? Yours does not look like the default Thunderbird options.

Helpful?

more options

I am using an add-on theme, but the colors were always fine until the TB update. I have tried several other themes with the same result. The TB system and light themes display properly.

Helpful?

more options

david said

I am a bit confused. In one of your responses, you indicate that the colors go black in other than the light or system theme. That comment indicates that the screen has white background and black text when the light theme is selected. True? If not, please clarify. On your question about the message pane, that is set at tools>general and the 'colors' button. On that, please check and verify that the box for 'use system colors is NOT ticked.

Yes, when the system or light theme is selected, the BG is white and the text is black. The USE System Colors box is not checked.

Helpful?

more options

I am not at all sure what your problem is then. It seems you want to use your addon theme, and that is why you see the dark screen, since everything is fine when you use the Light theme? If that is true, then the 'problem' may be that your custom theme may need to be updated. Thunderbird is not responsible for whether addon features work properly. Please clarify. Thank you.

Helpful?

more options

Okay, once again, the theme I was using, "A light in Space" by Madonna worked fine for the last year or so. It has not been updated, it it the same version, 1.0 , that I installed back then, but immediately upon the TB update to version 100 or so, the BG and text were changed. I have tried several other themes from the Mozilla website, and all exhibit the same behavior. So, apparently, the coding used to set the FG and text colors has changed so they don't interpret those properly in any but the TB supplied default themes.

FYI, I did a fair amount of coding years ago, so I know all about the law of intended consequences. Every now and then they pop up when least expected.

I'll consider the matter closed, since you have no logical explanation.

Thank you for your help.

Helpful?

more options

Primarily the setting for "Use hardware acceleration" is one of the first places to stop when odd graphics issues arise. There is no correct setting, I had it turned off for years by raising it as a bug. However the developers know better and turned the default on a couple of releases ago because Mozilla only test their code with it enabled. So we are back to the old days of odd display graphics because of video drivers and the Mozilla platform not playing well together. Note that there is no "correct setting" any driver can cause issues on a new release. So toggle what you have either to on or off.

Helpful?

more options

There is no setting in Thunderbird to enable or disable hardware acceleration that I can find.

Helpful?

more options

Helpful?

more options

Makes no difference.

Helpful?

more options

FWIW I'm having the same problem: TB 102 makes every theme other than Light render the folder and message list panes as black background. Frankly I'd rather not have white background either, but a nice pastel color. Can't find any way to do that.

Helpful?

more options

Stan48, Well, it's obvious to me that TB has broken some themes when run in Win7, but no one wants to admit it because they don't want to fix a problem that only affects Win7. I have another computer with TB 102 on it, and the same theme as the one I run on the Win7 machine has the proper BG and text colors. Unless someone discovers a fix, I guess we're out of luck.

Helpful?

  1. 1
  2. 2
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.