Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TLS 1.0 and 1.1 discontinuation ... ... ... being restricted by my mail server

  • Akukho zimpendulo
  • 1 inale nkinga
  • 10 views
more options

Recently ... ... ... about the same time I got a message concerning Thunderbird that certain systems will --- as of Oct 5 --- not allow e-mail transfers between the TB e-mail client and their systems due to TB [supposedly] using the older "TLS 1.0 and 1.1" encryption protocols, I got this message when I logged on to my primary e-mail server "MAIL.COM", so to check my e-mail and spam filters on their system, using Firefox 104.0.2:


This is what I get when I first log on:

Your browser is not supported.

We generally support the following browsers: Google Chrome, the latest version of Safari, Internet Explorer 11 and later, Firefox from version 33, Opera from version 10. To fully utilize the functionalities of your mail.com mailbox, we recommend using the latest version of your browser. Download Browser for free

The mail.com mailbox is also available with limited functionality.

(The browser they offer shows only for Google and Android Apps. Not for a "DESKTOP" version, to note.)


When I am logged in, I "AM" limited to "JUST" the e-mail section.

LUCKILY, I do not use their "CLOUD" or "CALENDAR" or other features, or I would "ALREADY" be blocked out of using such.

That FF does use 1.2 and 1.3, yet I "AM getting the above message and "AM" being restricted by "MAIL.COM" due to it claiming FF is NOT using the newer protocols, is there a fix to clear this.

Recently ... ... ... about the same time I got a message concerning Thunderbird that certain systems will --- as of Oct 5 --- not allow e-mail transfers between the TB e-mail client and their systems due to TB [supposedly] using the older "TLS 1.0 and 1.1" encryption protocols, I got this message when I logged on to my primary e-mail server "MAIL.COM", so to check my e-mail and spam filters on their system, using Firefox 104.0.2: This is what I get when I first log on: '''''Your browser is not supported.''''' '''''We generally support the following browsers: Google Chrome, the latest version of Safari, Internet Explorer 11 and later, Firefox from version 33, Opera from version 10. To fully utilize the functionalities of your mail.com mailbox, we recommend using the latest version of your browser. Download Browser for free''''' '''''The mail.com mailbox is also available with limited functionality.''''' (The browser they offer shows only for Google and Android Apps. Not for a "DESKTOP" version, to note.) When I am logged in, I "AM" limited to "JUST" the e-mail section. LUCKILY, I do not use their "CLOUD" or "CALENDAR" or other features, or I would "ALREADY" be blocked out of using such. That FF does use 1.2 and 1.3, yet I "AM getting the above message and "AM" being restricted by "MAIL.COM" due to it claiming FF is NOT using the newer protocols, is there a fix to clear this.

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.