Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to upgrade Firefox 88 to Firefox 104

more options

Hello - I've been looking around the Firefox site, and the Internet in general, and so far haven't found out the answer to my question: how do I get Firefox 104 to work on my Linux Mint 18.2 Cinnamon Sonya 32 bit? Specifically what I haven't been able to determine is whether or not I first need to upgrade my Linux, which I suspect. And if so, what's the minimum level of the OS that is required? I may be overlooking the simple answers, but so far I cannot find them. And so far the Firefox website upgrade feature does nothing that I can detect. Thank you for any assistance - Doug.

Hello - I've been looking around the Firefox site, and the Internet in general, and so far haven't found out the answer to my question: how do I get Firefox 104 to work on my Linux Mint 18.2 Cinnamon Sonya 32 bit? Specifically what I haven't been able to determine is whether or not I first need to upgrade my Linux, which I suspect. And if so, what's the minimum level of the OS that is required? I may be overlooking the simple answers, but so far I cannot find them. And so far the Firefox website upgrade feature does nothing that I can detect. Thank you for any assistance - Doug.

Isisombululo esikhethiwe

Thank you for your replies. I'll act on them as soon as possible.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

"And so far the Firefox website upgrade feature does nothing that I can detect." To clarify, in other words the Firefox auto-upgrade feature stopped downloading upgrades some time ago. However the on-demand download of version 104 does work to place the files on my computer, but I don't want to start the installation of 104 until I'm sure that I don't first need to upgrade to some more recent level of Linux, or have done that - Doug.

Helpful?

more options

The release notes contain the following link to system requirements.

https://www.mozilla.org/en-US/firefox/104.0/system-requirements/

Helpful?

more options

You appear to be running Firefox from the Ubuntu repositories. When you OS reaches EOL then your Firefox version will no longer be updated and you would have to switch to Firefox from the Mozilla server.

Helpful?

more options

Isisombululo Esikhethiwe

Thank you for your replies. I'll act on them as soon as possible.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.