Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox updates causing problems

  • 3 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu j9ritchie

more options

Hi,

So far this year, Firefox updates are causing problems.

Sometimes it updates in the middle of my seeing patients.

It used to give me the option of restoring all tabs. Now it no longer permits that option, so I have to painstakingly go through my recent history and add each needed tab - very time-consuming and annoying. I don't want to switch to Chrome but may have to as I have to use it anyway for sites that don't support Firefox.

Hi, So far this year, Firefox updates are causing problems. Sometimes it updates in the middle of my seeing patients. It used to give me the option of restoring all tabs. Now it no longer permits that option, so I have to painstakingly go through my recent history and add each needed tab - very time-consuming and annoying. I don't want to switch to Chrome but may have to as I have to use it anyway for sites that don't support Firefox.

Isisombululo esikhethiwe

Hi j9ritchie, I'm sorry you're having this problem. The way you can fix it is by disabling Automatic Updates. To do this, press the three lines in the top right corner and go to settings. From here, scroll down until you see Firefox updates and click on where it says "Check for updates but let you choose to install them" and uncheck "Use a background service to install updates." This should fix it.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

Hi j9ritchie, I'm sorry you're having this problem. The way you can fix it is by disabling Automatic Updates. To do this, press the three lines in the top right corner and go to settings. From here, scroll down until you see Firefox updates and click on where it says "Check for updates but let you choose to install them" and uncheck "Use a background service to install updates." This should fix it.

more options

Hi j9ritchie I understand your pain. I also went throug that, unfortunatly there is no propper way to avoid this issue. There are some web extensions for FireFox to reduse the problem, for example notepad extension just to keep important stuff there so you dont need scour the history everytime it happens. There is a prophecy that someday FireFox will care about this and will finally stop making this problem hahah I hope it will help.

more options

Thank you very much! I'm glad I'm not alone in this and hope Firefox will solve the problem. In the meantime, I'll do what you suggested.