Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can receive e-mails via my google account, but not send them. I have done all that is prescribed.

  • 7 uphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu Toad-Hall

more options

After upgrading on my Mac Pro 2010 to Thunderbird 91.10 I couldn't access my Google account. I found some suggestions (e.g. change to 0auth) - and eventually am able to receive e-mails. I still can't send them - not even when I went back to 91.4 (when I could send e-mails). I am being asked the password for my Google account, but when I fill in the correct one, I am again asked for my password - etc. I use the correct one as evidenced by the fact that I can access my Google account via Safari. I have contacted Google One. I followed their suggestion to accept Thunderbird on my Google account. I still can't send e-mails. Google One just now suggested that I no longer use Thunderbird as it does not seem to satisfy their safety standards. I don't want to do that (I like the lay-out). The alternative is to cancel my Google account. Please help: what is wrong - or if I am to blame, what am I doing incorrectly?

After upgrading on my Mac Pro 2010 to Thunderbird 91.10 I couldn't access my Google account. I found some suggestions (e.g. change to 0auth) - and eventually am able to receive e-mails. I still can't send them - not even when I went back to 91.4 (when I could send e-mails). I am being asked the password for my Google account, but when I fill in the correct one, I am again asked for my password - etc. I use the correct one as evidenced by the fact that I can access my Google account via Safari. I have contacted Google One. I followed their suggestion to accept Thunderbird on my Google account. I still can't send e-mails. Google One just now suggested that I no longer use Thunderbird as it does not seem to satisfy their safety standards. I don't want to do that (I like the lay-out). The alternative is to cancel my Google account. Please help: what is wrong - or if I am to blame, what am I doing incorrectly?

Isisombululo esikhethiwe

I have been trying to find the buttons you mentioned. I found them. I made the changes as you suggested. My main problem was that I overlooked the left hand column. I do have some experience with the Mac (since the first mac), but I continue to overlook things (but I often succeed after trying again and again - sometimes for hours).

Eureka! I can now send e-mails again!

Thank you for your time and patience. They are greatly appreciated! You really helped.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

re : am being asked the password for my Google account, but when I fill in the correct one, I am again asked for my password

It sounds like as Oauth has already been set up, so gmail expects the auto Oauth to work, so when you are prompted to enter password which you are doing because google ask for it, it does not like it because it expects Oauth. Basically well confused. I've seen this occur when the incoming and outgoing OAuth was not set up at same time. See if the following gets both back in sync.

Server SEttings: Make sure the incoming and the outgoing Authentication method is set up for OAuth I presume you have already allowed cookies in Thunderbird otherwise you would not have been able to get incoming working.

Menu icon > Preferences > Privacy & Security Passwords section click on 'Saved Passwords' Click on 'Show Passwords' Then remove all the stored passwords for gmail including the oauth one. I mean remove the entire line for whatever is stored: imap:// mailbox:// smtp:// oauth:// Select line and click on 'Remove'

Exit Thunderbird Wait a few moments for background processes to complete as files get updated. Start Thunderbird You will get the google prompt, enter email address and password and allow Thunderbird access.

Report back on results -

Helpful?

more options

re :Google One just now suggested that I no longer use Thunderbird as it does not seem to satisfy their safety standards.

It just proves how little they know or care. I'm using gmail imap with OAuth2 - it has no problems.

Okulungisiwe ngu Toad-Hall

Helpful?

more options

Thank you for your advice! Highly appreciated.

As to your first point, in Server settings there is no distinction between ingoing and outgoing Oauth. Where should I look? I am using version 91.4. I have indeed allowed cookies as suggested.

As to your second point, I have done as you suggest. I have removed the password, restarted. I got the prompt, I entered my e-mail address and password and have allowed access.

Unfortunately, I still can't send - although I can receive.

In the list of passwords, I can't find the password I used. It is now 1//03tQ5xY and some more symbols ... Definitely not the password I used.

Any idea?

Helpful?

more options

re : In the list of passwords, I can't find the password I used. It is now 1//03tQ5xY and some more symbols ... Definitely not the password I used.

that is the OAuth token. You never need to use that Oauth2 token, only Thunderbird need it to access the mail account.

re :As to your first point, in Server settings there is no distinction between ingoing and outgoing Oauth.

One Oauth token stored in Password section should be used for both incoming and outgoing. So it is possible you have not got the Outgoing Server Set up to use Oauth or you have set up the mail account to use the wrong outgoing server.

  • Right click on gmail pop/imap account name in Folder Pane and select 'Settings'

This opens the Account Settings in new tab The pop/imap account name should be selected Look bottom right for Outgoing Server (SMTP)

  • Click on 'Edit Server _SMTP' button

I'm assuming the account is set up to use the correct outgoing server - so the 'Username' would be the gmail account full email address.

  • If yes, the Username is the correct gmail email address then Set Authentication Method : OAuth2

If the Username is not the correct gmail address, then do not edit anything - you have to do this by another method. Let me know if it is wrong and I'll post info on how to proceed. Otherwise keep following instructions.

  • Click on OK

Now set the incoming authentication - this may already be correct.

  • select 'Server Settings' for gmail account
  • Set Authentication Method : OAuth2

Then clear the saved password again which in your case may be just the OAuth token.

  • Menu icon > Preferences > Privacy & Security
  • Passwords section
  • click on 'Saved Passwords'
  • Click on 'Show Passwords'
  • Then remove all the stored passwords for gmail including the oauth one.
  • I mean remove the entire line for whatever is stored: imap:// mailbox:// smtp:// oauth://
  • Select line and click on 'Remove'

Exit Thunderbird Wait a few moments for background processes to complete as files get updated. Start Thunderbird You will get the google prompt, enter email address and password and allow Thunderbird access.

Report back on results -

Helpful?

more options

re :As to your first point, in Server settings there is no distinction between ingoing and outgoing Oauth.

One Oauth token stored in Password section should be used for both incoming and outgoing.

OK. That is clear.

So it is possible you have not got the Outgoing Server Set up to use Oauth or you have set up the mail account to use the wrong outgoing server.

Right click on gmail pop/imap account name in Folder Pane and select 'Settings' This opens the Account Settings in new tab The pop/imap account name should be selected Look bottom right for Outgoing Server (SMTP)

Click on 'Edit Server _SMTP' button I'm assuming the account is set up to use the correct outgoing server - so the 'Username' would be the gmail account full email address.

'I can't find the Edit server SMTP button. I have attached a screenshot. Maybe I am in the wrong place? I use Thunderbird version 91.4.'

If yes, the Username is the correct gmail email address then Set Authentication Method : OAuth2

'Done.'

If the Username is not the correct gmail address, then do not edit anything - you have to do this by another method. Let me know if it is wrong and I'll post info on how to proceed. Otherwise keep following instructions.

Click on OK

'No OK button?'

Now set the incoming authentication - this may already be correct.

select 'Server Settings' for gmail account Set Authentication Method : OAuth2 Then clear the saved password again which in your case may be just the OAuth token.

Menu icon > Preferences > Privacy & Security Passwords section click on 'Saved Passwords' Click on 'Show Passwords' Then remove all the stored passwords for gmail including the oauth one. I mean remove the entire line for whatever is stored: imap:// mailbox:// smtp:// oauth:// Select line and click on 'Remove' Exit Thunderbird Wait a few moments for background processes to complete as files get updated. Start Thunderbird You will get the google prompt, enter email address and password and allow Thunderbird access.

'Done. Unfortunately, problem persists.'

Report back on results -

Helpful? Yes

Helpful?

more options

Isisombululo Esikhethiwe

I have been trying to find the buttons you mentioned. I found them. I made the changes as you suggested. My main problem was that I overlooked the left hand column. I do have some experience with the Mac (since the first mac), but I continue to overlook things (but I often succeed after trying again and again - sometimes for hours).

Eureka! I can now send e-mails again!

Thank you for your time and patience. They are greatly appreciated! You really helped.

Helpful?

more options

Good to hear all is working properly.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.