Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF for ios

  • 5 uphendule
  • 1 inale nkinga
  • 17 views
  • Igcine ukuphendulwa ngu James

more options

I recently saw FF was available for ios. I tried to download it, but my iphone is only on ios 12.5.5, with no further updates to higher numbers, and FF now only seems to support 13+ But I see numerous older references to support for 12. Where do I find it?

I recently saw FF was available for ios. I tried to download it, but my iphone is only on ios 12.5.5, with no further updates to higher numbers, and FF now only seems to support 13+ But I see numerous older references to support for 12. Where do I find it?

Okulungisiwe ngu doesn't suffer arrogance well

All Replies (5)

more options

Hi doesn't suffer arrogance well,

You can try to check out these links: https://www.mozilla.org/en-US/firefox/ios/12.0/system-requirements/ https://www.mozilla.org/en-US/firefox/all/#product-ios-release

Hope it helps you!

Helpful?

more options

Thanks but they don't work. They direct to the "most recent version" which won't support below ios 13.0. I want something besides the "most recent version" so it will support my 2 year old phone. I know both Apple and Microsoft aren't bashful about telling you to just buy something new, (easy when it's not their money) but I'm not a power phone user, my current one is just fine. I would just like something besides Safari for a browser.

Helpful?

more options

With iOS 12.5.5 according to wikipedia I'm guessing it is the old iPhone 6 or 6 Plus that was released September 19, 2014 and discontinued September 7, 2016. So it is not a new phone if it is only 2yrs old.

If you installed a then compatible version in past, you may be able to reinstall from you purchased list, you cannot side load a older version like you could with say Android.

Helpful?

more options

Correct, it is an iphone 6. It was purchased new in either March or April of 20, from the bottom feeder Tracfone. It was brought out of retirement for a time, which is the time frame I bought it. Research suggests it was manufactured in October of '18.

So is this then an Apple issue, saying buy a new phone cheapskate, we won't let you install anything that's not new and shiny? Or did Mozilla discontinue it? I'm not that familiar with Apple products, I'm a PC guy and typically finding an older version of software isn't difficult. Might be the Apple interface, but I'm used to computers, phones are computers, but not exactly, they're amazing for what they are, but often exasperating.

I've looked a bit more and it seems no browsers are available for my phone, except the bundled Safari.

It appears Firefox used to be available for 12.5.5, but no longer? Any other way or has Apple just locked it down to promote new sales?

So... anyone?

Okulungisiwe ngu doesn't suffer arrogance well

Helpful?

more options

The iOS requirements has made it so iOS 13.0 is the minimum required to run the iOS Firefox for a while now.

With a Android tablet/phone you can potentially have the option of side load installing a older version .apk but with iOS/iPadOS nope.

Apple well just stopped supporting the iPhone 6 with iOS 12.5.5 being the last update. They still do support the iPhone 6S / 6S Plus with current OS update according to wikipedia, so if only you managed to get one of those models instead.

I acquired a old iPad mini 2nd gen as my Mom did not want it anymore. It is also stuck with iOS 12.5.5 as last update. It has been interesting looking for games that will run on it besides some old ones like PvZ 1+2 and such. At least the Youtube and WeatherNetwork apps work and Safari is ok and VLC is great for using the iPad as a media player.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.