On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Manage Exceptions does not work (always allowed websites are never saved between sessions) Bug/Ignorance?

  • 3 uphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu cor-el

more options

I am using Firefox Version 101.0.1 (64-bit) for Desktop Windows 10 64bit (newest version (see question date for lookup info)).

This problem I could not find anywhere in this Firefox self support community. I think I discovered a bug in the firefox settings, but it might just be me missing something, but I doubt it, being familiar with the settings and them being clearly worded.

I can not seem to get my firefox to save the website always allowed to keep cookies stored between sessions (and their cookies / other data obviously also don't get saved between sessions). - maybe there arises a problem with the setting of never saving history between sessions?

Please, have a look at my current settings below (two screenshots): <image 1 (longer one)> <image 2 (shorter one, custom history settings)>

The settings being written as they are should mean that the always allowed websites should never have their cookies deleted between sessions, regardless of their history (their being visited) being deleted. To me this is frustrating and appears like a bug and not a feature.

Maybe is history is deleted all site permissions and data get deleted, too? - (If yes, that is clearly not what the settings suggest, and if it is supposed to work like this, I strongly suggest the Firefox Dev.s team to fix the confusion or add some feature work-around to suit my use-case. The internet is not a safe place anymore, generally, but some parts are, let me trust your settings do what the say they do, at the very least. Thanks in advance.)

I am using Firefox Version 101.0.1 (64-bit) for Desktop Windows 10 64bit (newest version (see question date for lookup info)). This problem I could not find anywhere in this Firefox self support community. I think I discovered a bug in the firefox settings, but it might just be me missing something, but I doubt it, being familiar with the settings and them being clearly worded. I can not seem to get my firefox to save the website always allowed to keep cookies stored between sessions (and their cookies / other data obviously also don't get saved between sessions). - maybe there arises a problem with the setting of never saving history between sessions? Please, have a look at my current settings below (two screenshots): <image 1 (longer one)> <image 2 (shorter one, custom history settings)> The settings being written as they are should mean that the always allowed websites should never have their cookies deleted between sessions, regardless of their history (their being visited) being deleted. To me this is frustrating and appears like a bug and not a feature. Maybe is history is deleted all site permissions and data get deleted, too? - ''(If yes, that is clearly not what the settings suggest, and if it is supposed to work like this, I strongly suggest the Firefox Dev.s team to fix the confusion or add some feature work-around to suit my use-case. The internet is not a safe place anymore, generally, but some parts are, let me trust your settings do what the say they do, ''at the very least''. Thanks in advance.)''
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Let's address two different things:

Before Firefox 99, enabling "Clear history when Firefox closes" and selecting "Cookies" would clear all cookies without honoring any exceptions; a complete wipe. That shoudl be fixed as of Firefox 99.

However, in your second screenshot, you are clearing "Site Settings" (formerly labeled "Site Preferences"). That box refers to all site-specific settings and permissions such as preferred zoom levels, popup permission, AND cookie permissions. You need to uncheck that box.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

Let's address two different things:

Before Firefox 99, enabling "Clear history when Firefox closes" and selecting "Cookies" would clear all cookies without honoring any exceptions; a complete wipe. That shoudl be fixed as of Firefox 99.

However, in your second screenshot, you are clearing "Site Settings" (formerly labeled "Site Preferences"). That box refers to all site-specific settings and permissions such as preferred zoom levels, popup permission, AND cookie permissions. You need to uncheck that box.

Helpful?

more options

Hey there, thank you very much for your answer, I was hoping I was missing something embarassing like that.. (The marked solution is the complet solution and explanation to my problem)

My apologies to the Firefox Dev Team for my demanding wording. It would still be nice to have some warning messages about the dependencies / side-effects of combinations of settings, this would be not just a minor overhaul, though, it seems to me (as it can get complicated).

I wasn't expecting such a quick answer, great, made my day!

Helpful?

more options

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.