Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Version compatible with mac OSX 10.11

  • 1 baphendule
  • 1 inale nkinga
  • 38 views
  • Igcine ukuphendulwa ngu James

more options

I just downloaded the latest version of firefox. When I tried opening it the message said it is not compatible with Max OSX 10.11. I now need to download a later version of firefox. Which version is compatible with Mac OSX 10.11? thank you!

I just downloaded the latest version of firefox. When I tried opening it the message said it is not compatible with Max OSX 10.11. I now need to download a later version of firefox. Which version is compatible with Mac OSX 10.11? thank you!

Isisombululo esikhethiwe

Firefox since Fx 79.0 and later including the current Fx 100 and Fx 91 ESR requires Mac OS X 10.12 (ten.twelve) at minimum.

Besides updating your OS to Mac OS X 10.12 (ten.twelve) or later, the most current Firefox version you can install on mac OS 10.11 is Fx 78.15.0 ESR though it is EOL with no more updates.

https://support.mozilla.org/en-US/kb/firefox-mac-osx-users-esr

https://www.mozilla.org/firefox/78.0/system-requirements/ https://www.mozilla.org/firefox/79.0/system-requirements/ https://www.mozilla.org/firefox/100.0/system-requirements/

In case you ever need the Firefox 78.15.0esr file. https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/en-US/ other locales at https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

Firefox since Fx 79.0 and later including the current Fx 100 and Fx 91 ESR requires Mac OS X 10.12 (ten.twelve) at minimum.

Besides updating your OS to Mac OS X 10.12 (ten.twelve) or later, the most current Firefox version you can install on mac OS 10.11 is Fx 78.15.0 ESR though it is EOL with no more updates.

https://support.mozilla.org/en-US/kb/firefox-mac-osx-users-esr

https://www.mozilla.org/firefox/78.0/system-requirements/ https://www.mozilla.org/firefox/79.0/system-requirements/ https://www.mozilla.org/firefox/100.0/system-requirements/

In case you ever need the Firefox 78.15.0esr file. https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/en-US/ other locales at https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/