Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

No Firefox Preview for PDFS

  • 10 uphendule
  • 1 inale nkinga
  • 54 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello :) For some time now my firefox doesn't allow me to preview PDFs. If I open it, it gets downloaded at the same time which I don't need. I already tried the thing with renaming the handlers.json to handlersOLD.json but it didn't work :( does anyone know how to fix this?

Hello :) For some time now my firefox doesn't allow me to preview PDFs. If I open it, it gets downloaded at the same time which I don't need. I already tried the thing with renaming the handlers.json to handlersOLD.json but it didn't work :( does anyone know how to fix this?

All Replies (10)

more options
more options

All you can do is change the download destination. It was one of related changes deliberately made by Mozilla in version 98.

more options

You can right-click an item in the Downloads panel and choose "Always Open Similar Files" to make it open automatically and add this action to "Settings -> General -> Applications". You can change the "Save" action to "Always Ask" or "Open in Firefox" if available.

more options

cor-el schrieb

You can right-click an item in the Downloads panel and choose "Always Open Similar Files" to make it open automatically and add this action to "Settings -> General -> Applications". You can change the "Save" action to "Always Ask" or "Open in Firefox" if available.

Thanks for the help but unfortunately it still downloads everything even if I change it to "open in firefox" :(

But apparently Firefox changed the whole download system as Terry said:

Terry- schrieb

All you can do is change the download destination. It was one of related changes deliberately made by Mozilla in version 98.

Thanks anyway! :)

more options

This new feature is called “Optimized Download Flow” which skips the download confirmation dialog completely and downloads the file automatically. This feature has been developed to minimize the interruptions and allow users to focus on other tasks. One more thing! The downloaded files will be immediately saved on your hard disk. Firefox will no longer put them in Temp folder.

Many Firefox users many not like this new download behavior and want to bring back old classic download prompt window in Firefox.

Fortunately, there is a hidden secret preference/flag available in Firefox which can be modified to disable the new download behavior and re-enable classic download prompt window in Firefox newer versions.

If you also want to restore classic download prompt box in Firefox, following steps will help you:

1. Open Firefox and type about:config in the addressbar and press Enter. It’ll show you a warning message, click on “Accept the Risk and Continue” button. It’ll open Firefox’s hidden secret advanced configuration page i.e. about:config page.

2. Now type improvements in Search filter box and look for following preference in the window:

browser.download.improvements_to_download_panel

The preference value is set to true by default, which means the new automatic download behavior is activated and enabled in Firefox.

3. To deactivate and disable the new behavior and restore classic download prompt feature, double-click on browser.download.improvements_to_download_panel preference and set it to false. Alternatively, you can click on the Toggle icon given next to the preference name.

https://media.askvg.com/articles/images8/Classic_Download_Confirmation_Prompt_Mozilla_Firefox.png

That’s it. Now try to download a file in Firefox browser and you’ll get back the classic download prompt dialog box in Firefox.

PS: To restore default settings and enable new automatic download feature again in Firefox, set the above mentioned preference to true.

A word of WARNING-this changes your default settings and there could be unforeseen issues (but my experiences so far is that it reverted back to the previous "ask" what to do). So take caution when doing this. If not sure go to the link and read on it.

https://www.askvg.com/tip-restore-classic-download-confirmation-prompt-in-mozilla-firefox/

more options

Evidently selecting Open in Firefox results in the file being saved in your temp folder.

more options

How did it work for you before?

The default setting for PDFs on the Settings page, Applications list, is "Open in Firefox". This opens PDFs in a tab in Firefox with the original URL showing in the address bar. The file is stored in the web content cache along with web pages, images, etc. If this option is missing, a policy may be blocking it in your Firefox.

The other options are:

  • Always Ask - Show the download dialog so you can choose how to open the download
  • Use [relevant application] - Save the file and send it over to your PDF reader application
  • Save File - Save the file and don't do anything else

All of these save the file to disk -- Firefox can't pass a file over to another application without saving it somewhere. Before Firefox 98, the Open and Use options saved the file in the system Temp folder (for Windows and Linux users). Starting in Firefox 98, the Open and Use options save the file in the folder set next to "Save files to:" on the Settings page.

If cleaning up files is a hassle, you could consider this workaround that I'm using:

(1) Change the default download folder to a "temp" folder you create (2) Set Firefox to always ask where you want to save a file so you can choose a real folder when you want to keep the file

On the Settings page, it looks like this:

more options

donthavecow schrieb

This new feature is called “Optimized Download Flow” which skips the download confirmation dialog completely and downloads the file automatically. This feature has been developed to minimize the interruptions and allow users to focus on other tasks. One more thing! The downloaded files will be immediately saved on your hard disk. Firefox will no longer put them in Temp folder. Many Firefox users many not like this new download behavior and want to bring back old classic download prompt window in Firefox. Fortunately, there is a hidden secret preference/flag available in Firefox which can be modified to disable the new download behavior and re-enable classic download prompt window in Firefox newer versions. If you also want to restore classic download prompt box in Firefox, following steps will help you: 1. Open Firefox and type about:config in the addressbar and press Enter. It’ll show you a warning message, click on “Accept the Risk and Continue” button. It’ll open Firefox’s hidden secret advanced configuration page i.e. about:config page. 2. Now type improvements in Search filter box and look for following preference in the window: browser.download.improvements_to_download_panel The preference value is set to true by default, which means the new automatic download behavior is activated and enabled in Firefox. 3. To deactivate and disable the new behavior and restore classic download prompt feature, double-click on browser.download.improvements_to_download_panel preference and set it to false. Alternatively, you can click on the Toggle icon given next to the preference name. https://media.askvg.com/articles/images8/Classic_Download_Confirmation_Prompt_Mozilla_Firefox.png That’s it. Now try to download a file in Firefox browser and you’ll get back the classic download prompt dialog box in Firefox. PS: To restore default settings and enable new automatic download feature again in Firefox, set the above mentioned preference to true. A word of WARNING-this changes your default settings and there could be unforeseen issues (but my experiences so far is that it reverted back to the previous "ask" what to do). So take caution when doing this. If not sure go to the link and read on it. https://www.askvg.com/tip-restore-classic-download-confirmation-prompt-in-mozilla-firefox/

thank you so much! this worked! :)

more options

When the browser.download.improvements_to_download_panel preference setting stops working (which will likely take place in an upcoming Firefox update) you will be back to where you started.

In addition to the options posted above, you should also consider using the default "Open in Firefox" setting for Portable Document Format (PDF) files in the Firefox Settings ->Applications list:

Fx91Applications-PDF-Win

This setting will open PDF files in Firefox's built-in PDF viewer, which does not save the PDF file to your computer. As jscher2000 said, this setting will store the PDF in the web content cache along with web pages, images, etc.

When you open PDF files in Firefox's built-in viewer, you can use the download Fx98PDFviewer-DownloadButton button in the PDF viewer's toolbar if you decide you want to save the PDF file to your computer. You can then open the PDF file in another viewer, if you wish, as explained in the View PDF files in Firefox or choose another viewer article.

more options

(I have removed the solution because I think that it shouldn't be encouraged to disable the improvements_to_download_panel pref)