Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I edit autofill entries

  • 24 uphendule
  • 4 zinale nkinga
  • 418 views
  • Igcine ukuphendulwa ngu mateng1

more options

A website MultiSafepay.com has saved my CVV number in Firefox.

How do I edit the autofill data?

I can't get to the same payment page, to be in a position to delete it.

Most links on this matter refer to:

 Options => Privacy & Security => Forms and Autofill

However in my Version: Firefox 98.0.1 (64 bit) running on an up to date Windows 10 this feature is missing or deprecated.

Can anyone say how I could edit/delete this specific entry, or point me in the direction of where this data is stored?

In the mean time I can't recommend using Firefox for entering critical security data, where websites can allow the storage of CVV numbers.

A website MultiSafepay.com has saved my CVV number in Firefox. How do I edit the autofill data? I can't get to the same payment page, to be in a position to delete it. Most links on this matter refer to: Options => Privacy & Security => Forms and Autofill However in my Version: Firefox 98.0.1 (64 bit) running on an up to date Windows 10 this feature is missing or deprecated. Can anyone say how I could edit/delete this specific entry, or point me in the direction of where this data is stored? In the mean time I can't recommend using Firefox for entering critical security data, where websites can allow the storage of CVV numbers.

Isisombululo esikhethiwe

In the end I used DB Browser for SQLite:

 https://sqlitebrowser.org/dl/

I then opened formhistory.sqlite and on opening the moz_formhistory table I can then see in plain text under an a rather appropriately name fieldname my CVV.

It is shameful that Firefox can write to a database with secure information without allowing the user to easily delete entries.

Using DB Browser I am able to delete the entry and write the file. When I restart the browser "about:restartrequired" I can confirm the offending autofill entry is gone.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (20)

more options

Hi firefox236, Try this: Click on the Menu button and select Settings In the search bar at the top, type in credit The page will then show the Forms and Autofill section where you can edit Credit Card information. Hope this helps!

Okulungisiwe ngu RobertJ

Helpful?

more options

Many thanks for your help.

This is the issue, I cannot see "Forms and Autofill"

If I go onto Menu(hamburger sign) -> Settings I get the "about:preference" page.

If I type in "credit" (without parenthesis) I get:

Search Results Sorry! There are no results in Settings for "credit". Need help ............

Annoyingly I can't copy highlighted text on this page

As I have said this is critical where a less than honest website like MultiSafepay.com saves my security number. I think users should be informed not to use Firefox for secure payments.

Helpful?

more options

firefox236 said

Many thanks for your help. This is the issue, I cannot see "Forms and Autofill" If I go onto Menu(hamburger sign) -> Settings I get the "about:preference" page. If I type in "credit" (without parenthesis) I get: Search Results Sorry! There are no results in Settings for "credit". Need help ............ Annoyingly I can't copy highlighted text on this page As I have said this is critical where a less than honest website like MultiSafepay.com saves my security number. I think users should be informed not to use Firefox for secure payments.

Hello! The following help article might help you: Automatically fill in credit card data on Web forms

Helpful?

more options

Try this: You can check this pref on the about:config page.

   extensions.formautofill.creditCards.enabled = true 

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

   https://support.mozilla.org/en-US/kb/about-config-editor-firefox


Then see if the Forms and Autofill section appears.

Thanks to cor-el

Okulungisiwe ngu RobertJ

Helpful?

more options

Thanks for the suggestion.

This is what I found when I searched for "extensions.formautofill.credit" in the search bar.

extensions.formautofill.creditCards.available true extensions.formautofill.creditCards.enabled true extensions.formautofill.creditCards.hideui false extensions.formautofill.creditCards.used 0

It is already set to "true". Which does seem the default value that I might have expected.

If I search over "Show only modified preferences" for "autof" I get no results.

Helpful?

more options

If I'm not mistaken extensions.formautofill.creditCards.used = 0 means that there are no credit cards stored. I can't explain why the Forms and Autofill section isn't showing up. A quick look at the kb article Automatically fill in credit card data on Web forms says that CVV number is not saved anyway. It looks like you'll have to get into your Acccount settings and Payment Methods at MultiSafePay.

Okulungisiwe ngu RobertJ

Helpful?

more options

What I therefore surmise is that MultiSafePay is using a conventional form entry for the CVV number.

It's not my account, but one I was obliged to use to pay an invoice.

The fact it is a CVV number is perhaps a red-herring. The point is I want to be able to edit these autofill entries, which is something I can't do. Nor does anyone seem to know where autofill data is actually stored..

Helpful?

more options

You could try clearing cookies and storage for the site. On the Settings page, Privacy & Security panel, Cookies & Site Data section, the "Manage Data" button allows removing data for a specific site.

Helpful?

more options

Oh, and Firefox's general purpose form history feature is covered by this article: Control whether Firefox automatically fills in forms.

Helpful?

more options

If you are outside of the US & Canada you might need to force the Forms & Autofill section on. See this thread for more - Cannot find "Forms and Autofill" section

Helpful?

more options

No cookie file is associated with MultiSafePay.com

I've also looked at the contents of the cookie files using MZ Cookie Viewer and I can't find the offending saved CVV number. Cookies with the site I was paying through also don't seem to hold any relevant data.

In short I don't feel I have progressed very far, apart from highlighting that I wouldn't recommend using Firefox for secure payments.

Helpful?

more options

firefox236 said

No cookie file is associated with MultiSafePay.com I've also looked at the contents of the cookie files using MZ Cookie Viewer and I can't find the offending saved CVV number. Cookies with the site I was paying through also don't seem to hold any relevant data.

I think MZ Cookie Viewer shows the cookies, but not the contents of DOM storage (e.g., Local Storage).

Did you try deleting cookies and storage for the site using Manage Data to see whether that makes any difference?

If you don't want to try deleting, while on the site that you believe has stored the data, open the Storage Inspector using Shift+F9 and check the Local Storage category.

Form History

Did you confirm that the number is not saved in form history by either looking to delete a form history suggestion or turning off form history? The reference for that was: Control whether Firefox automatically fills in forms.

Helpful?

more options

RobertJ said

If you are outside of the US & Canada you might need to force the Forms & Autofill section on. See this thread for more - Cannot find "Forms and Autofill" section

That is interesting. I have

 extensions.formautofill.available	detect

Whereas the article you reference has:

 extensions.formautofill.available = "on" (String) 

If I set this to "on" ie not "true" I now get Forms and Autofill, but the saved addresses and credit card information entries are both empty.

Anyway, I think we have established this is not related to credit, and is a general autofill.

The question remains, where can this autofill data be edited and where is it stored?

Helpful?

more options

Whoops, our posts crossed.

I don't know of a stand-alone program to conveniently view the contents of the formhistory.sqlite file. I am familiar with online SQLite database browsers, such as

https://inloop.github.io/sqlite-viewer/

but you might not be completely comfortable doing that on a website, even though the scripts to read the data run locally in the page and no data is uploaded, as far as I can tell.

Helpful?

more options

Isisombululo Esikhethiwe

In the end I used DB Browser for SQLite:

 https://sqlitebrowser.org/dl/

I then opened formhistory.sqlite and on opening the moz_formhistory table I can then see in plain text under an a rather appropriately name fieldname my CVV.

It is shameful that Firefox can write to a database with secure information without allowing the user to easily delete entries.

Using DB Browser I am able to delete the entry and write the file. When I restart the browser "about:restartrequired" I can confirm the offending autofill entry is gone.

Helpful?

more options

I wonder how all other sites handle this because I've never heard of this problem before. Here's my guess: sites usually apply autocomplete="off" to form fields to signal browsers that this field should not be autocompleted, which in Firefox means it also should not be saved to form history.

Is it possible that the payment site forgot to do that? Or do you have any add-ons that modify autocomplete behavior?

Helpful?

more options

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the webpage to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press "Delete" or "Shift+Delete" to delete the highlighted entry

Note that hovering with the mouse doesn't work.

Helpful?

more options

cor-el said

You can use these steps to remove saved items from an autocomplete drop-down list.
  1. click the (empty) input field on the webpage to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press "Delete" or "Shift+Delete" to delete the highlighted entry
Note that hovering with the mouse doesn't work.

That might work for some sites, but in this case two invoices were due and two payments were made. I don't have the opportunity to get to the same webpage again.

Helpful?

more options

jscher2000 said

I wonder how all other sites handle this because I've never heard of this problem before. Here's my guess: sites usually apply autocomplete="off" to form fields to signal browsers that this field should not be autocompleted, which in Firefox means it also should not be saved to form history. Is it possible that the payment site forgot to do that? Or do you have any add-ons that modify autocomplete behavior?

It does seem that way. It's a bad show for a payment website to "forget" such a fundamental behaviour. You would have thought there would have been a review with a tick-sheet before it became live.

However I still think it is shoddy for Firefox not to have the ability to edit autocomplete entries.

Okulungisiwe ngu firefox236

Helpful?

more options

jscher2000 said

I wonder how all other sites handle this because I've never heard of this problem before. Here's my guess: sites usually apply autocomplete="off" to form fields to signal browsers that this field should not be autocompleted, which in Firefox means it also should not be saved to form history. Is it possible that the payment site forgot to do that? Or do you have any add-ons that modify autocomplete behavior?

It does seem that way. It's a bad show for a payment website to "forget" such a fundamental behaviour. You would have thought there would have been a review with a tick-sheet before it became live.

However I still think it is shoddy for Firefox not to have the ability to edit autocomplete entries.

Helpful?

  1. 1
  2. 2
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.