Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 52-x error "Access Denied You don't have permission to access...this site...on this server. Reference#...

  • 20 uphendule
  • 1 inale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu hmp

more options

This error shows from all latest version, going back as far as version 52, whenever I click to check out on some shopping websites, like Costa.co.uk and currys.co.uk. For troubleshooting purposes, I copied a portable Firefox setup and added a gift card and filled in my email address on Costa website: https://gifting.costa.co.uk/home/gift-card/thank-you-little-gc.aspx I clicked to check out, but the error page shows instead of allowing me to proceed to payment. Clearing cookies/history, disabling, add-ons/running Firefox in troubleshoot mode, updating to newer Firefox doesn't solve the problem. I tried troubleshoot mode, deleting all add-ons, re-setting all about:config settings to default, but no avail. I tried deleting misc files and folders from Firefox directories and noticed that the problem is caused by: "content-prefs.sqlite" and "prefs.js", but after deleting those files or the profile folder, the error doesn't show on first load, but if I try a second time after clearing history, the error message starts showing again. The site loads next page only if I delete the data folder or use a fresh install with no add-ons/configurations. This didn't used to happen. I spent a lot of time setting up my Firefox so don't want to start over.

How can I solve this issue?

This error shows from all latest version, going back as far as version 52, whenever I click to check out on some shopping websites, like Costa.co.uk and currys.co.uk. For troubleshooting purposes, I copied a portable Firefox setup and added a gift card and filled in my email address on Costa website: https://gifting.costa.co.uk/home/gift-card/thank-you-little-gc.aspx I clicked to check out, but the error page shows instead of allowing me to proceed to payment. Clearing cookies/history, disabling, add-ons/running Firefox in troubleshoot mode, updating to newer Firefox doesn't solve the problem. I tried troubleshoot mode, deleting all add-ons, re-setting all about:config settings to default, but no avail. I tried deleting misc files and folders from Firefox directories and noticed that the problem is caused by: "content-prefs.sqlite" and "prefs.js", but after deleting those files or the profile folder, the error doesn't show on first load, but if I try a second time after clearing history, the error message starts showing again. The site loads next page only if I delete the data folder or use a fresh install with no add-ons/configurations. This didn't used to happen. I spent a lot of time setting up my Firefox so don't want to start over. How can I solve this issue?

All Replies (20)

more options

Please reply!

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:

Boot the computer in Windows Safe Mode with network support to see if that works better.

more options

There is no record of the website in history, because I already tried clearing my history and it didn't solve the issue. But I tried re-visiting site and clicking "Forget About This Site", but no improvement after visiting again. Nothing outside Firefox is blocking as a fresh portable installation works without me changing external factors.

more options
more options

After creating a new profile, the problem disappeared. Now what should I try?

more options

That means something about the old profile was causing the issue. It could be an add-on or a setting.

What you could do is continue using the new profile. If you want to get your add-ons back, reinstall them one at a time(restarting Firefox). And watch for the problem returning.

more options

But I removed all addons and then manually rest all adjusted settings in about:config and that didn't solve the issue either.

more options

Is there a way to copy all the firefox settings & configurations (minus addons) to a new profile, or add-ons minus Firefox settings/configs?

Okulungisiwe ngu hmp

more options

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

I take it the new profile is working without a problem, yes?

When you are ready, we can start moving parts of your old data and Copy it to the new profile.


First; open your file browser to the New profile;

Type about:support<enter> in the address box.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.


Second, open another file browser to the Old profile. You should see it on the directory "tree" in the first file browser. Right-click on that folder and select Open In New Window.


Warning ! ! Only Copy the files you are told. We will avoid anything that might cause problems. Here is the list of files;

cookies: cookies.sqlite Do not bother. Cookies will be created when you return to the website. However, you will have to log in everywhere. And you may lose any settings that websites store on your computer.

extensions(add-ons, themes): it would be better to download them fresh. If you need to remember what add-ons you had, open the extensions sub-folder and look at the .xpi files


logins.json and key3.db [v58+]key4.db : These are the password files. Copy Both !

persdict.dat : custom dictionary - words you added to the dictionary

mimeTypes.rdf [v55+]handlers.json : What to do with what type of file.

places.sqlite : History and Bookmarks.

prefs.js : Your settings. Note: If you were having problems, this could be contaminated.

cert8.db [v58+]cert9.db and possibly cert_override.txt : Stores all your security certificate settings and any SSL certificates you have imported into Firefox. If removed, the cert8.db, cert9.db file will be replaced.

search.json.mozlz4 : file stores the user-installed search engines that are available in the Firefox v47+

search.sqlite file and searchplugins folder store the search engines that are available in the Firefox Search bar before Firefox v47


Copy these files from the old to the new. You may get a message that the files already exist. Choose to over-write for each file.

more options

I've found the culprit. In a new profile, after copying what you said above (including prefs.js), the problem did NOT re-occur. But as soon as I copied over the "safebrowsing" folder (which contained extra files), or as soon as I manually enabled Fingerprinters under Privacy & Security in settings, the problem re-occurred. Worse, even if I deleted the extra files in safebrowsing, or even if I didn't copy the folder to begin with, and simply toggled to enable and disable fingerprinters, the problem persisted.

more options

This suggests, none of my extensions need to be re-created from scratch. It's entirely a firefox fault!

more options

hmp said

But as soon as I copied over the "safebrowsing" folder (which contained extra files), or as soon as I manually enabled Fingerprinters under Privacy & Security in settings, the problem re-occurred. Worse, even if I deleted the extra files in safebrowsing, or even if I didn't copy the folder to begin with, and simply toggled to enable and disable fingerprinters, the problem persisted.

SafeBrowsing and blocking known fingerprinting servers are enabled out of the box, so if those were the culprit, then we would expect these sites not to work correctly for ALL Firefox users. Since removing those had no effect, I think that was a coincidence and there must be another factor.

It's strange that you can interact with the site up to a certain point without difficulty, and only encounter the problem when checking out. Perhaps the issue triggers when the scripts from the payment processor are loaded or, if payment involves being redirected to a processor's site, when their site loads.

This error message is characteristic of a web application firewall, which sites use to block bots and other suspicious traffic. Bot traffic may have missing or altered headers (such as the referring site header), incomplete form submissions (certain security parameters missing), unusual cookies, or other unusual parameters.

Can you recall altering any privacy settings related to cookies, or preferences in about:config related to referer or user agent?

Could you modify some connection settings and test whether they make any difference. On the Settings page --

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

-- click in the tiny search box at the top of the page and type proxy -- Firefox should filter to the "Settings" button, which you can click.

In the top section, select "No proxy".

In the bottom section, if DNS over HTTPS is enabled, uncheck that box.

Click OK to save the changes.

Any difference?

more options

This is so annoying, I can't load FirefoxPortable.exe if I move it to a different location. So I can't test 2 portable setups. I just installed fresh to a non-desktop folder, which even contains FirefoxPortable sub-folder, but it won't load unless I load from desktop. It's supposed to be portable!

more options

As I said above, as soon as I enable fingerprinters, the issue occurs.

more options

hmp said

As I said above, as soon as I enable fingerprinters, the issue occurs.

Do you mean in the Custom section of Tracking Protection settings?

That is enabled by default on all Firefox installations.

more options

Yes. But now for some reason, the issue is happening immediately after any fresh installs even on desktop, without changing any settings. I have to check registry for anything firefox might be doing there to prevent me launching firefox portable after copying into subcategories.

Okulungisiwe ngu hmp

more options

So annoying because these issues only affects firefox.

more options

Found so many firefox entries in registry, but nothing pointing to "...Desktop/FirefoxPortable."

more options

I don't think Portable uses the Registry.

However, maybe something about it looks different to websites than regular Firefox. ??

more options

I downloaded it fresh from portableapps.com