Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox icon reappears on desktop after being deleted

  • 8 uphendule
  • 2 zinale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu Bob R

more options

I'm using Windows 10 Pro and Firefox 97.0.1 I do not want the Firefox icon on my desktop (I already have it pinned to my taskbar). I delete the shortcut, but it reappears each time I log in. Removing it requires me to have a coworker with admin privileges come supply a password - it's not tenable for me to keep bugging her every day. I cannot find the setting to suppress the re-creation of the desktop icon; where is it located? I prefer Firefox, but if there's no solution to this I will have to uninstall it and switch to a different browser.

I'm using Windows 10 Pro and Firefox 97.0.1 I do not want the Firefox icon on my desktop (I already have it pinned to my taskbar). I delete the shortcut, but it reappears each time I log in. Removing it requires me to have a coworker with admin privileges come supply a password - it's not tenable for me to keep bugging her every day. I cannot find the setting to suppress the re-creation of the desktop icon; where is it located? I prefer Firefox, but if there's no solution to this I will have to uninstall it and switch to a different browser.
Ama-screenshot ananyekiwe

All Replies (8)

more options

This problem still exists with Firefox 98.0.2 and Win 10 build 17134. Every time I reboot the computer, a new Firefox shortcut reappears. Just as with the OP, I have to get an Admin to remove it. This is getting infuriating!

more options

I wonder whether this is linked to Firefox checking whether it is the default browser? Once Firefox becomes your default, you might not be able to uncheck that box. Here is how you manipulate that setting under the covers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.shell.checkDefaultBrowser and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

No idea whether that will make any difference. (My desktop is too messy to notice a new icon, sadly.)

more options

I did that, and hoped it would help - it didn't.

I thought it might be some kind of Desktop Restore function the company might have added, so I "refresh"ed the desktop after canning the shortcut. It didn't come back.... until 10 minutes later when the computer "locked". I unlocked it, and there that shortcut is!

I'm willing to believe it isn't Firefox' fault, but I'm hoping...

more options

Is there any difference between the desktop shortcut and the pinned shortcut in where they point?

more options

Oh! You had to ask that! :-) I just deleted it! :-(

Well, I'm almost done (at work) for the day. I'm relatively sure it'll come back during shutdown (now) and restart (tomorrow morning), so I can answer this at that time.

My shortcut (the one I use) is "C:\Program Files\Mozilla Firefox\firefox.exe" - pretty benign...

FWIW, My Win10 Home (21H2) in Parallels on my Mac, does not exhibit this behavior (it's also, default Browser, 98.0.2)

The work machine (I should have said) is Win10 Enterprise.

more options

A possible issue is a secondary install in

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

But sometimes the icon just doubles for no apparent reason. In that case you might need to surrender the pinned one and pin the one that keeps coming back.

more options

Hmmmmmm...

I see there is a folder at ~\Program Files (x86). It's "Mozilla Firefox" and it contained a link to enable Webex.

I trashed the folder (the Webex link will d/l when I need it anyway), rebooted the machine. It didn't come back.

No guarantees, of course. Whether it comes back or not, I'll report here tomorrow.

more options

Well, it came back. I don't know when (sometime after boot - I'd have noticed it then).