Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox will not display my index.html if I type 'www.mysite.com/index.html'

  • 2 uphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu valkyri

more options

I'm developing my company's website, located at www.deccopainting.com - which displays the home page fine, but when I link back from other pages using "index.html" - firefox displays a message from my host provider suggesting that index.html is not there.

index.html is in fact there, obviously, and the link to index.html displays in Chrome, Edge, and every single other browser I've tested it on, it's only Firefox that does not display index.html if it's actually typed in the URL bar or linked from another page.

You can test this by first going to www.deccopainting.com (site is not complete) and then going to www.deccopainting.com/index.html.

I am aware I can use <a href="www.deccopainting.com"> instead, but why should I have to do this, when every other browser on the market works as it should??

I'm developing my company's website, located at www.deccopainting.com - which displays the home page fine, but when I link back from other pages using "index.html" - firefox displays a message from my host provider suggesting that index.html is not there. index.html is in fact there, obviously, and the link to index.html displays in Chrome, Edge, and every single other browser I've tested it on, it's only Firefox that does not display index.html if it's actually typed in the URL bar or linked from another page. You can test this by first going to www.deccopainting.com (site is not complete) and then going to www.deccopainting.com/index.html. I am aware I can use <a href="www.deccopainting.com"> instead, but why should I have to do this, when every other browser on the market works as it should??

Okulungisiwe ngu valkyri

Isisombululo esikhethiwe

Hmm, no error messages here.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just clear the Cached web content, not all site data)

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

Hmm, no error messages here.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (just clear the Cached web content, not all site data)

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

more options

Clearing the cache worked, thanks!